buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Assaf Arkin" <ar...@intalio.com>
Subject Re: problems with scala
Date Mon, 05 May 2008 15:36:29 GMT
try sudo update_rubygems

Assaf

On Mon, May 5, 2008 at 1:12 AM, Olivier POPPON <opoppon@gmail.com> wrote:

> At the office, here is what I did (I am on OS X as well)
>
> >buildr -- version
> ==> 1.2.0
> I tried to type buildr (only) and I have the 2 questions with the prompt
> (perfect !)
>
> So I decide to upgrade it:
> >sudo gem update buildr
> ==> the process starts and finish properly. Tells me that 1.3.0 is
> installed
>
> Now I type buildr
> ==> error. Rake is not high enough (version) ???? I thought the gem update
> was suppose to get all dependencies for me...
>
> So I update rake
> > sudo gem update rake
>
> and I had to do the same for: Antwrap, hoe and finally RubyGem
>
> For RubyGem I did:
> >sudo gem update --system
>
> now everything is broken.
> I can't type rails, or buildr.
>
> I have this error : Could not find RubyGem rubyforge (>= 0.4.4)
> (Gem::LoadError)
>
> Again sorry to bother you with all these...I am not to familiar with the
> gem package manager (it shows :)
>
>
> On 4 mai 08, at 22:00, n8han wrote:
>
>
>> I don't have any GEM_* variables in my env. As long as you are getting the
>> right macports executables (under /opt/local/bin) when you run `which
>> ruby`
>> and `which gem` you should be fine to `gem install buildr` into the new
>> gem
>> repository. `gem env` is also a nice sanity check.
>>
>> Nathan
>> --
>> View this message in context:
>> http://www.nabble.com/problems-with-scala-tp17045732p17050669.html
>> Sent from the Buildr - User mailing list archive at Nabble.com.
>>
>>
>


-- 
CTO, Intalio
http://www.intalio.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message