buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shane Witbeck" <sh...@digitalsanctum.com>
Subject Re: best way to override buildr dependency versions
Date Wed, 25 Jun 2008 18:51:06 GMT
Thanks Assaf. That worked.

On Wed, Jun 25, 2008 at 12:56 PM, Assaf Arkin <arkin@intalio.com> wrote:
> On Wed, Jun 25, 2008 at 9:43 AM, Shane Witbeck <shane@digitalsanctum.com> wrote:
>> I'm working on fixing a file truncation issue which hopefully can be
>> solved by just changing the versions of net-ssh and net-sftp.
>>
>> What's the best way to override/change the versions of these
>> dependencies in buildr?
>
> Most of the dependencies are listed in buildr.gemspec.  The ones that
> are not are specific to the JRuby/MRI packaging, and go in the
> Rakefile.  So to upgrade net-ssh/-sftp you only need to edit
> buildr.gemspec and package a new version of Buildr.
>
> Assaf
>
>
>>
>> I have already filed an issue requesting the newer versions but cannot
>> wait for another release.
>>
>> --
>> -Shane
>>
>



-- 
-Shane

Mime
View raw message