buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Assaf Arkin" <ar...@intalio.com>
Subject Re: installing buildr 1.3.1 on Windows/JRuby
Date Wed, 04 Jun 2008 01:27:43 GMT
Pending a new release, we have two workarounds:

1.  Install from sources:

$ svn co http://svn.apache.org/repos/asf/incubator/buildr/trunk buildr
$ cd buildr
$ rake install
or
$ jruby -S rake install

2.  Remove these two gems:
gem uninstall rubyforge -v 1.0.0
gem uninstall hoe-1.5.3

Note that you will need to repeat #2 if you run gem update again, as
it will bring back these dependencies, until we publish a new release
of Buildr (the new one will work with the more recent rubyforge/hoe
releases).

Assaf


On Fri, May 30, 2008 at 10:15 AM,  <EricReece@wellsfargo.com> wrote:
> I'm a newb so take it easy on me please.  Windows XP, JRuby 1.1.2,
> Buildr 1.3.1 - using windows command prompt - not cygwin.
>
> I'm getting errors/version issues with hoe 1.5.3 => rubyforge 1.0.0 and
> buildr => rubyforge 0.4.5.  It looks like hoe 1.5.3 and rubyforge 1.0.0
> have just been released within the last week or so.  Like I said I'm a
> newb so I don't know how to deal with versioning issues like this.  Any
> help would be appreciated.
>
> Here is the error when simply trying to run buildr using the -v option:
>
> C:/dev/jvm/jruby-bin-1.1.2/jruby-1.1.2>jruby -S buildr -v
>
> C:/dev/jvm/jruby-bin-1.1.2/jruby-1.1.2/lib/ruby/site_ruby/1.8/rubygems.r
> b:140:in
>  `activate': can't activate rubyforge (= 0.4.5), already activated
> rubyforge-1.0.0] (Gem::Exception)
>        from
> C:/dev/jvm/jruby-bin-1.1.2/jruby-1.1.2/lib/ruby/site_ruby/1.8/rubygems.r
> b:155:in `activate'
>        from
> C:/dev/jvm/jruby-bin-1.1.2/jruby-1.1.2/lib/ruby/site_ruby/1.8/rubygems.r
> b:154:in `each'
>        from
> C:/dev/jvm/jruby-bin-1.1.2/jruby-1.1.2/lib/ruby/site_ruby/1.8/rubygems.r
> b:154:in `activate'
>        from
> C:/dev/jvm/jruby-bin-1.1.2/jruby-1.1.2/lib/ruby/site_ruby/1.8/rubygems.r
> b:49:in `gem'
>        from C:/dev/jvm/jruby-bin-1.1.2/jruby-1.1.2/bin/buildr:18
>
> C:/dev/jvm/jruby-bin-1.1.2/jruby-1.1.2>Jruby -S gem list --local
>
> *** LOCAL GEMS ***
>
> Antwrap (0.7.0)
> archive-tar-minitar (0.5.2)
> builder (2.1.2)
> buildr (1.3.1)
> ci_reporter (1.5.1)
> highline (1.4.0)
> hoe (1.5.3)
> jruby-openssl (0.2)
> net-sftp (2.0.0)
> net-ssh (2.0.1)
> rake (0.8.1)
> rspec (1.1.3)
> rubyforge (1.0.0, 0.4.5)
> rubyzip (0.9.1)
> xml-simple (1.0.11)
>
> Thanks
> Eric Reece
>
>



-- 
CTO, Intalio
http://www.intalio.com

Mime
View raw message