buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Assaf Arkin" <ar...@intalio.com>
Subject Re: Trying to install buildr
Date Mon, 23 Jun 2008 21:19:56 GMT
On Sun, Jun 22, 2008 at 4:10 AM, Ittay Dror <ittay.dror@gmail.com> wrote:
>
>
>
> hemant-6 wrote:
>>
>> Then, install rjb,
>>
>> gem install rjb
>>
>>
> yes, well, i've tried. didn't work. then i had to look more closely at the
> error message, learn a bit about gem and do
>  sudo env JAVA_HOME=$JAVA_HOME gem install rjb -v 1.1.2
>  sudo env JAVA_HOME=$JAVA_HOME gem install net-ssh -v 2.0.1
>  sudo env JAVA_HOME=$JAVA_HOME gem install net-sftp -v 2.0.0
>  sudo env JAVA_HOME=$JAVA_HOME gem install rubyforge -v 0.4.5
>  sudo env JAVA_HOME=$JAVA_HOME gem install hoe -v 1.3.0
>  sudo env JAVA_HOME=$JAVA_HOME gem install rspec -v 1.1.3
>
> for things to work.
>
> not the best start for wanting to get a quick feel of buildr (not the worst
> either)

If you're using Ubuntu, or any other Debian-based Linux, then you
probably ran into a "feature" of Debian.  They include an
intentionally crippled version of RubyGems.  The only solution I can
think of, but I don't use Ubuntu often enough, is to apt-get uninstall
rubygems, and instead install the official RubyGems distribution (the
script will do the later for you).

http://incubator.apache.org/buildr/getting_started.html#linux

Assaf

>
> ittay
> --
> View this message in context: http://www.nabble.com/Trying-to-install-buildr-tp18052207p18053535.html
> Sent from the Buildr - User mailing list archive at Nabble.com.
>
>

Mime
View raw message