buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vesa Vilhonen <vesa.vilho...@cs.helsinki.fi>
Subject Why there are strict versions in depencies?
Date Thu, 05 Jun 2008 12:38:23 GMT
Hello,

I just installed buildr 1.3.1 with rubygem tool on os x and were  
wondering buildr's depencies. Why is there strict versions required?  
It caused troubles when I used buildr and some module loaded before  
loaded newer version of the rubyforge than buildr's gem specification  
allows. I got around the problem by modifying specification to let  
rubyforge versions newer than 0.4.5 and didn't notice any problems.

- Vesa Vilhonen


s.add_dependency(%q<rjb>, [">= 1.1.0", "<= 1.1.2"])
s.add_dependency(%q<rake>, ["= 0.8.1"])
s.add_dependency(%q<builder>, ["= 2.1.2"])
s.add_dependency(%q<net-ssh>, ["= 2.0.1"])
s.add_dependency(%q<net-sftp>, ["= 2.0.0"])
s.add_dependency(%q<rubyzip>, ["= 0.9.1"])
s.add_dependency(%q<highline>, ["= 1.4.0"])
s.add_dependency(%q<Antwrap>, ["= 0.7.0"])
s.add_dependency(%q<rspec>, ["= 1.1.3"])
s.add_dependency(%q<xml-simple>, ["= 1.0.11"])
s.add_dependency(%q<archive-tar-minitar>, ["= 0.5.2"])
s.add_dependency(%q<rubyforge>, [">= 0.4.5"]) <- worked better like this


Mime
View raw message