buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Boisvert" <>
Subject Re: Bug with repositories.local =
Date Tue, 29 Jul 2008 21:01:57 GMT

Interesting, I had not tried that yet.  The current bootstrap process is
conditioned by RJB/Ant wanting many of the libraries declared in advance, so
it's tricky to evaluate anything in the Buildfile until everything has been
loaded.   Perhaps a solution would be to agree on a convention for the local
repo directly in the project (e.g. "maven2") so that it doesn't have to be
defined in the Buildfile.


On Tue, Jul 29, 2008 at 12:05 PM, hemant <> wrote:

> Hi,
> I have been using buildr for building my Scala projects and its been
> working pretty well. With 1.3.2, for newly added dependencies(on scala
> testing libs), I added maven repositories and buildr fetched them and
> put them as required. But while building my project, buildr is
> ignoring the directive:
> repositories.local = "dependency"
> and it still tries to look for those jars in ~/.m2 directory. I worked
> around the problem, by declareing an environment variable,
> "local_repo", but  it seems that changes of "repositories.local = "
> are taking place a little late in the building order and while during
> actual build jars are getting picked from correct location, but search
> still takes place in default directories.
> --
> Let them talk of their oriental summer climes of everlasting
> conservatories; give me the privilege of making my own summer with my
> own coals.

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message