buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Assaf Arkin <ar...@intalio.com>
Subject Re: buildr on ruby 1.9.1?
Date Thu, 05 Feb 2009 07:32:18 GMT
On Wed, Feb 4, 2009 at 10:55 PM, Ittay Dror <ittay.dror@gmail.com> wrote:
> I've tried to install  buildr on top of ruby 1.9.1 (ruby gems 1.3.1) and
> these are the errors i get:
>
> <internal:gem_prelude>:249:in `push_gem_version_on_load_path': undefined
> method `<=>' for nil:NilClass (NoMethodError)
>   from <internal:gem_prelude>:14:in `gem'
>   from /usr/bin/buildr-1.9:18:in `<main>'
>
>
> Any help?

I get the same error on my machine whenever I try to run a gem that
was installed with Ruby 1.8. Installing it again with 1.9 solves this.

Buildr has a dependency on at least one gem that is not 1.9 compatible (RSpec).

Assaf

>
> Ittay
>
>
>
>

Mime
View raw message