buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Assaf Arkin <ar...@intalio.com>
Subject Re: Keeping executable bits on files (Buildr::Filter)
Date Mon, 09 Feb 2009 07:16:11 GMT
On Thu, Jan 29, 2009 at 12:36 PM, Alex Boisvert <boisvert@intalio.com>wrote:

> Hi Henrik,
>
> Late reply but I guess better than no reply at all!
>
> On Tue, Jan 27, 2009 at 1:00 AM, Henrik Thostrup Jensen
> <thostrup@gmail.com>wrote:
>
> > When copying files using Buildr:Filter, any executable bit set on
> > files disappear.
> > This is somewhat annoying :-). Is there a way to fix this?
>
>
> Yes, but it sounds like we'll need a volunteer to write the fix and test
> it.  Feel free to open a Jira and give it your best shot if you have the
> guts for it.


Here's the issue:
https://issues.apache.org/jira/browse/BUILDR-144

Assaf



>
>
> Also, is there an easy way to roll up several sub-projects into a
> > single directory (for release or deployment)
> > Currently I'm doing this filter, but there might be an easier way.
>
>
> I'm not 100% clear about what you mean.   Typically the form of packaging
> you use (.war, .ear, ...) addresses this.
>
>
>
> > And two unrelated questions:
> >
> > 1.3.4 gets a bit verbose to stdout, even with --silent (e.g., clean
> > emits alot of rm -fr command)
> > Is there a way to make it as silent as 1.3.3?
>
>
> Do you want to send in a patch? :)
>
>
> > 1.3.4 didn't really speed up things. Maybe the actual task execution,
> > but there is still a ~10 second startup delay. jirb takes around 2
> > seconds to start. Is this common, or is JRuby misconfigured somehow?
>
>
> I have an 5-8 second delay on my system.  I think it's within the expected
> norms without knowing more about your system configuration.
>
> alex
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message