buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sakari Isoniemi <sakari.isoni...@gmail.com>
Subject Re: Cannot connect to remote gem server
Date Tue, 17 Mar 2009 17:21:15 GMT
Hai Assaf

I updatet Gems 1.3.1 manually and remote connections
started to work, but comand "gem install buildr" still fails
to some library mismatch error.

My colleque told that windows is difficult Ruby environment and he suggested
instantRails installation.

I did it and it works out of the box, no gem updates needed.

2009/3/17 Assaf Arkin <arkin@intalio.com>

> On Tue, Mar 17, 2009 at 3:07 AM, Sakari Isoniemi
> <sakari.isoniemi@gmail.com>wrote:
>
> > I have a problem with my office computer to do gem update
> > with Ruby128-26 running command
> >
> > gem update --system
> >
> > Updating RubyGems...
> > ERROR:  While executing gem ... (Gem::RemoteFetcher::FetchError)
> >    Invalid argument(Errno::EINVAL)
> > In my home computer this works, so it is some
> > kind of network problem ?
>
>
> Ironically, it might happen because you're running an older version of
> RubyGems which can't unpack the newer version you're trying to install.
>
> So download the RubyGems 1.3.1 directly from this URL and then gem install
> it:
>
> http://rubyforge.org/frs/download.php/45904/rubygems-update-1.3.1.gem
>
> Assaf
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message