buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Grotzke <martin.grot...@javakaffee.de>
Subject Re: Allow user to specify jmock dependency
Date Tue, 21 Apr 2009 21:55:52 GMT
On Tue, 2009-04-21 at 14:16 -0700, Alex Boisvert wrote:
> I have an old SVN local branch here where I upgraded to jmock 2.5.1 and the
> two main changes were:
> 
> -jmock artifacts are now under "org.jmock" in the maven repositories;
> -a new dependency on hamcrest 1.1+ (both hamcrest-core and hamcrest-library)
> 
> I'm just waiting for an opportune moment to make the upgrade...
Will this moment be before the 1.3.4 release? :)

Cheers,
Martin


> 
> alex
> 
> On Tue, Apr 21, 2009 at 2:05 PM, Assaf Arkin <arkin@intalio.com> wrote:
> 
> > On Tue, Apr 21, 2009 at 1:19 PM, Martin Grotzke <
> > martin.grotzke@javakaffee.de> wrote:
> >
> > > Hi,
> > >
> > > I just need to use jmock-2 instead of jmock-1, as I need to proxy a
> > > class (not interface).
> > >
> > > Is this a big deal?
> >
> >
> > http://buildr.apache.org/languages.html#java
> >
> > Scroll down to the discussion about JUnit, also covers changing the version
> > of JMock.
> >
> > Assaf
> >
> >
> > >
> > >
> > > There's an issue related to this:
> > > https://issues.apache.org/jira/browse/BUILDR-150
> > >
> > > Thanx && cheers,
> > > Martin
> > >
> > >
> >

Mime
View raw message