buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jon Barksdale <jon.barksd...@gmail.com>
Subject groovy compiler version
Date Thu, 02 Apr 2009 18:28:48 GMT
Hi,
I have recently been experimenting with buildr, and I can't for the life of
me figure out how to get the groovy compiler to use groovy 1.6.0.  This is
probably because my ruby foo is weak, but I've tried everything I've seen in
the documentation, both on the site and in the code around the groovy
module, and I'm still missing it.  Could anyone help point me in the right
direction?

Here is the top of my buildfile (the commented out parts are things that
I've tried, no luck):
require 'buildr'
#artifact_ns("Buildr::Compiler::Groovyc").groovy =  '1.6.0'
#artifact_ns["Buildr::Compiler::Groovyc"].groovy =  '1.6.0'
#artifact_ns("Buildr::Groovy::Groovyc").groovy =  '1.6.0'
#artifact_ns["Buildr::Groovy::Groovyc"].groovy =  '1.6.0'
#artifact_ns :groovy => '1.6.0'
#artifact_ns.use :groovy => '1.6.0'
require 'buildr/groovy'
#artifact_ns("Buildr::Compiler::Groovyc").groovy =  '1.6.0'
#artifact_ns["Buildr::Compiler::Groovyc"].groovy =  '1.6.0'
#artifact_ns("Buildr::Groovy::Groovyc").groovy =  '1.6.0'
#artifact_ns["Buildr::Groovy::Groovyc"].groovy =  '1.6.0'


and here is my build.yaml:

artifacts:
  groovy: org.codehaus.groovy:groovy-all:jar:1.6


Any help would be greatly appreciated.

Thanks,

Jon

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message