buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Maier <michael.ma...@vivai.de>
Subject Using buildr after upgrading to snow leopard Mac OS 10.6
Date Thu, 10 Sep 2009 21:53:11 GMT
Hi buildr-people,

maybe this information will help all people who used buildr with ruby  
until they updated the Mac OS X to snow leopard. After the update java  
1.5 is gone and you can only use java 1.6. And then the trouble  
begins. But we are all men! First of all, I got strange ruby errors  
like:

Buildr aborted!
uninitialized constant REXML::ParseException

Very strange, since it worked before the update and  
REXML::ParseException exists. So why thinks ruby there is no  
REXML::ParseException? I have no idea and time to search for reasons  
why ruby have a problem with REXML::ParseException. Google have no  
answers, too. The only hint that I found was the error was cause by  
the xmpp4r gem. Disabling it, new errors come to light:

Buildr aborted!
can't create Java VM
/Library/Ruby/Gems/1.8/gems/buildr-1.3.4/lib/buildr/core/ 
application.rb:405:in `raw_load_buildfile'

Mmm...ok...I tried a few installation of rjb gem with severals  
configurations but no chance to get buildr running. Always "can't  
create Java VM". The solution is to use jruby. After installation  
jruby (1.2.0) and the gems

jruby -S gem install buildr
jruby -S gem install xmpp4r

I was able to run the current project! Yeah! Although buildr is ruby  
it runs better with java.

We like buildr very much! I hope the developers of buildr will remove  
rjb or get it running on Mac with 10.6. To call jetty I use system  
because with rjb it didn't work properly.

best regards

Michael



Mime
View raw message