buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mat Schaffer <>
Subject Re: Specs not running in my project
Date Thu, 01 Oct 2009 21:37:16 GMT
Thanks Alex! I'll give it a try and let you know.  I might also just  
look into requiring rspec 1.2.2 for now. And actually I was looking at  
the wrong gem folder before, it's actually 1.2.6 I'm getting the error  

On Sep 30, 2009, at 11:59 AM, Alex Boisvert wrote:

> Hi Mat,
> It seems some callbacks have changed in rspec 1.2.8 (or recent  
> version) which broke our custom report handler.   I have something  
> working with rspec now but JtestR fails...  I'm attaching my current  
> patch in case that's helpful to you.
> alex
> On Wed, Sep 30, 2009 at 8:17 AM, Mat Schaffer <> wrote:
> So yet more questions. I'm still working on getting buildr working  
> for the java-mateview component of redcar. I separated it out into  
> an "api" project which contains just the java and junit tests and a  
> "specs" project which contains the rspecs used to test ruby  
> integration. The problem now is that although everything appears to  
> load correctly, the rspec portion just shows: "0 examples, 0  
> failures" and I get an error that seems to be triggered by an empty  
> result.yaml.
> I get the same behavior when running the full java command (from  
> running with --trace) or jruby target/spec/runner.rb from the specs  
> folder. I also tried putting a raise in one of the ..._spec.rb file  
> and that worked, so it seems like the specs are getting loaded just  
> not executed.
> This is jruby 1.4.0dev (same behavior on 1.3.1), buildr-1.3.4-java,  
> rspec-1.2.8. I'm going to try a simple jruby+rspec test to see if  
> maybe there's a problem there, but I suspect it has something to do  
> with how runner.rb is getting constructed.
> Source is up at Thanks  
> in advance for any assistance or ideas.
> -Mat
> <patch.txt>

View raw message