buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicholas Andrews <...@jhu.edu>
Subject buildr negative argument
Date Sat, 02 Jan 2010 17:35:38 GMT
Hi!

On two machines now, I get the following error for a "Hello World"
buildr project.  I set up the directory structure as explained in the
"Quick Start," with one source file in src/main/scala.  I also tried
adding this line:

repositories.remote << "http://repo1.maven.org/maven2/"

to the buildfile, with the same results.  Note the "negative argument"
line, which seems weird.  Am I doing something wrong? I installed
buildr following the instructions on the website for Ubuntu,
line-per-line, which fetched version 1.3.5.

Cheers,
Nick

-- output --

$ buildr
mkdir -p /home/nick/.buildr
To use Buildr you need a buildfile. Do you want me to create one?:
1. From directory structure
2. Cancel
?  1
Created /home/nick/dev/scala_test/buildfile
(in /home/nick/dev/scala_test, development)
Downloading org.apache.ant:ant:jar:1.7.1
Downloading http://mirrors.ibiblio.org/pub/mirrors/maven2/org/apache/ant/ant/1.7.1/ant-1.7.1.jar
negative argument
Buildr aborted!
Failed to download org.apache.ant:ant:jar:1.7.1, tried the following
repositories:
http://www.ibiblio.org/maven2//

(See full trace by running task with --trace)

Mime
View raw message