buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Boisvert <alex.boisv...@gmail.com>
Subject Re: installation/checking install
Date Mon, 22 Feb 2010 18:22:44 GMT
Hi Adam,

I did a "gem update --system" this morning and it looks like changes in the
latest rubygems 1.3.6 release broke
buildr/packaging/version_requirement.rb...

I filed a bug for this and attached a quick patch to get you working,
http://issues.apache.org/jira/browse/BUILDR-378

alex

On Mon, Feb 22, 2010 at 6:07 AM, Adam Crain
<adam.crain@plymouthsystems.com>wrote:

> Hi Alex,
>
> Yes, I went through and did a fresh install of ruby and then did gem
> update --system this morning to verify.
>
> I end up with the same error message when I run buildr. I'm using the
> ruby 1.8.6 One Click Installer.
>
> Strangely enough, I get the same error when trying the install under
> cygwin. My previous problem with cygwin was just
> gcc not likely my JAVA_HOME path. Same error now:
>
> $ buildr
> /usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2503:in
> `const_missing': uninitialized constant Gem::Requirement::OP_RE
> (NameError)
>        from
> /usr/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buildr/packagin
> g/version_requirement.rb:24
>        from
> /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
> `gem_original_require'
>        from
> /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
>        from
> /usr/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buildr/packagin
> g/artifact_namespace.rb:17
>        from
> /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
> `gem_original_require'
>        from
> /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
>        from
> /usr/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buildr/packagin
> g/artifact.rb:19
>        from
> /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
> `gem_original_require'
>        from
> /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
>        from
> /usr/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buildr/packagin
> g.rb:17
>        from
> /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
> `gem_original_require'
>        from
> /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
>        from
> /usr/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buildr.rb:21
>        from
> /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
> `gem_original_require'
>        from
> /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
>        from
> /usr/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/bin/buildr:18
>        from /usr/bin/buildr:19:in `load'
>        from /usr/bin/buildr:19
>
>
> Here are the gems installed:
>
> $ gem list
>
> *** LOCAL GEMS ***
>
> Antwrap (0.7.0)
> archive-tar-minitar (0.5.2)
> builder (2.1.2)
> buildr (1.3.5)
> gemcutter (0.4.0)
> highline (1.5.2, 1.5.1)
> hoe (2.5.0, 2.3.3)
> json_pure (1.2.0)
> net-sftp (2.0.4, 2.0.2)
> net-ssh (2.0.20, 2.0.15)
> rake (0.8.7)
> rjb (1.1.9, 1.1.6)
> rspec (1.3.0, 1.2.8)
> rubyforge (2.0.3, 1.0.5)
> rubygems-update (1.3.6)
> rubyzip (0.9.4, 0.9.1)
> xml-simple (1.0.12)
>
>
> -----Original Message-----
> From: Alex Boisvert [mailto:alex.boisvert@gmail.com]
> Sent: Sunday, February 21, 2010 8:48 PM
> To: users@buildr.apache.org
> Subject: Re: installation/checking install
>
> Never seen this one before...  you may want to try running:
>
> gem update --system
>
> before installing buildr.
>
> alex
>
> On Sun, Feb 21, 2010 at 3:10 PM, Adam Crain
> <adam.crain@plymouthsystems.com>wrote:
>
> > I would like to give builder a whirl, but installation has proven less
> > that easy....
> >
> >
> >
> > So far I've tried windows and cygwin installs to no avail. I was able
> to
> > get the windows install to eventually run by explicitly specifying:
> >
> >
> >
> > gem install buildr -platform=mswin32
> >
> >
> >
> > However, now when I run buildr:
> >
> >
> >
> > >buildr
> >
> > C:/Ruby/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2503:in
> > `const_missing': u
> >
> > ninitialized constant Gem::Requirement::OP_RE (NameError)
> >
> >        from
> > C:/Ruby/lib/ruby/gems/1.8/gems/buildr-1.3.5-x86-mswin32/lib/buildr/
> >
> > packaging/version_requirement.rb:24
> >
> >        from
> > C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `ge
> >
> > m_original_require'
> >
> >
> >
> > Cygwin, didn't install at all. I've got JAVA_HOME defined, and am
> using
> > the ruby 1.8.6 binary installer. Ideas?
> >
> >
> >
> > Thanks,
> >
> > Adam
> >
> >
> >
> >
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message