buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Boisvert <alex.boisv...@gmail.com>
Subject Re: dependencies not used for groovyc
Date Wed, 24 Feb 2010 15:23:54 GMT
Try pushing JUnit into the JVM's classpath,

Java.classpath << "junit:junit:jar:4.4"

at the top of your buildfile.  This is something normally taken care under
the hood but maybe there's an issue with how the groovy support does it.

alex


On Wed, Feb 24, 2010 at 2:16 AM, Peter Schröder <ps@blau.de> wrote:

> hi,
>
> i have a problem migrating an existing groovy project from ant to buildr.
>
> while defining a
>
>  test.with 'junit:junit:jar:4.4'
>
> it wont get pushed down to the groovy compiler.
>
> please see the attachement for more information.
>
> kind reagards,
> peter
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message