buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antoine Toulme <anto...@lunar-ocean.com>
Subject Re: Buildr 1.4.0RC2 is out
Date Mon, 26 Apr 2010 18:33:50 GMT
Thanks for the bug. Comments below:

On Mon, Apr 26, 2010 at 11:19, Will Rogers <wjrogers@gmail.com> wrote:

> On Mon, Apr 26, 2010 at 1:34 PM, Antoine Toulme <antoine@lunar-ocean.com>
> wrote:
> > Also, can you please open a bug with the output of the testing you made ?
>
> https://issues.apache.org/jira/browse/BUILDR-427
>
> Also, I just realized I get an error at the end of "rake spec", too:
>
> rake aborted!
> Command C:/Ruby/bin/ruby.exe -I"lib"
> "C:/Ruby/lib/ruby/gems/1.8/gems/rspec-1.3.0/bin/spec"
> "spec/addon/drb_spec.rb" "spec/core/application_spec.rb"
> "spec/core/build_spec.rb" "spec/core/cc_spec.rb"
> "spec/core/checks_spec.rb" "spec/core/common_spec.rb"
> "spec/core/compile_spec.rb" "spec/core/extension_spec.rb"
> "spec/core/generate_spec.rb" "spec/core/project_spec.rb"
> "spec/core/test_spec.rb" "spec/core/transport_spec.rb"
> "spec/core/util_spec.rb" "spec/groovy/bdd_spec.rb"
> "spec/groovy/compiler_spec.rb" "spec/ide/eclipse_spec.rb"
> "spec/ide/idea7x_spec.rb" "spec/java/ant_spec.rb"
> "spec/java/bdd_spec.rb" "spec/java/cobertura_spec.rb"
> "spec/java/commands_spec.rb" "spec/java/compiler_spec.rb"
> "spec/java/emma_spec.rb" "spec/java/java_spec.rb"
> "spec/java/packaging_spec.rb" "spec/java/tests_spec.rb"
> "spec/packaging/archive_spec.rb"
> "spec/packaging/artifact_namespace_spec.rb"
> "spec/packaging/artifact_spec.rb" "spec/packaging/packaging_spec.rb"
> "spec/scala/bdd_spec.rb" "spec/scala/compiler_spec.rb"
> "spec/scala/tests_spec.rb" "spec/version_requirement_spec.rb" --format
> specdoc --format failing_examples:failed --format
> html:_reports/specs.html --backtrace --colour failed
>
> Am I missing something required for generating test output?
>
Not sure. If you run with --trace, it gives a lot more info and should send
a backtrace.

>
>
> > Will, the problem with the gem versions are something you need to fix on
>
> I downloaded
> http://people.apache.org/~toulmean/buildr/1.4.0RC3/dist/buildr-1.4.0.gem
> and installed it with "gem install buildr-1.4.0.gem". I have rspec
> (1.3.0, 1.2.9, 1.2.8) in "gem list rspec". What should I do to fix the
> problem? I also tried the file buildr-1.4.0-x86-mswin32.gem but got 59
> spec failures including the same rspec gem version errors.
>
The fix is to remove 1.3.0. What happens is that Buildr requires a few gems,
which lazily require rspec with version >0, and your system picks up the
latest version. When buildr gets around to dictate to start 1.2.9, rubygems
throws an error.

>
> I admit I don't understand the difference between the plain .gem and
> the -x86-mswin32.gem. I have been using the plain .gem because
> -x86-mswin32 doesn't match my ruby version string. Is that wrong?
>
You're not doing anything wrong. I'll open a new bug for that. The ruby
version of windows 7 changed, but I'm not sure if we need to change our
packaging much.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message