buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From KlaasJan Elzinga <klaasjanelzi...@gmail.com>
Subject Fwd: Unable to get buildr working
Date Tue, 06 Apr 2010 20:48:25 GMT
Hello,

I tried to install the buildr on my mac and get it to run. After install I
encountered https://issues.apache.org/jira/browse/BUILDR-384 I downgraded to
buildr version 1.3.3 and got buildr -v working.

After creating a simple buildfile I got:
$ buildr build
/Library/Ruby/Gems/1.8/gems/rake-0.8.1/lib/rake.rb:2237:in `const_missing':
uninitialized constant Gem::Requirement::OP_RE (NameError)
from
/Library/Ruby/Gems/1.8/gems/buildr-1.3.3/lib/buildr/java/version_requirement.rb:24
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `require'
from
/Library/Ruby/Gems/1.8/gems/buildr-1.3.3/lib/buildr/packaging/artifact_namespace.rb:17
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `require'
from
/Library/Ruby/Gems/1.8/gems/buildr-1.3.3/lib/buildr/packaging/artifact.rb:20
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `require'
from /Library/Ruby/Gems/1.8/gems/buildr-1.3.3/lib/buildr/packaging.rb:19
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `require'
from /Library/Ruby/Gems/1.8/gems/buildr-1.3.3/lib/buildr/java/pom.rb:18
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `require'
from /Library/Ruby/Gems/1.8/gems/buildr-1.3.3/lib/buildr/core/generate.rb:17
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `require'
from /Library/Ruby/Gems/1.8/gems/buildr-1.3.3/lib/buildr/core.rb:27
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `require'
from /Library/Ruby/Gems/1.8/gems/buildr-1.3.3/lib/buildr.rb:20
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `require'
from /Library/Ruby/Gems/1.8/gems/buildr-1.3.3/bin/buildr:19
from /usr/bin/buildr:19:in `load'
from /usr/bin/buildr:19

Ryby version: ruby 1.8.7 (2009-06-08 patchlevel 173) [universal-darwin10.0]

These are the installed gems:
$ gem list

*** LOCAL GEMS ***

actionmailer (2.3.5, 2.2.2, 1.3.6)
actionpack (2.3.5, 2.2.2, 1.13.6)
actionwebservice (1.2.6)
activerecord (2.3.5, 2.2.2, 1.15.6)
activeresource (2.3.5, 2.2.2)
activesupport (2.3.5, 2.2.2, 1.4.4)
acts_as_ferret (0.4.4, 0.4.3)
Antwrap (0.7.0)
archive-tar-minitar (0.5.2)
builder (2.1.2)
buildr (1.3.3)
capistrano (2.5.18, 2.5.2)
cgi_multipart_eof_fix (2.5.0)
daemons (1.0.10)
dnssd (1.3.1, 0.6.0)
fastthread (1.0.7, 1.0.1)
fcgi (0.8.8, 0.8.7)
ferret (0.11.6)
gem_plugin (0.2.3)
highline (1.5.2, 1.5.1, 1.5.0, 1.4.0)
hoe (2.6.0, 2.3.3, 1.11.0, 1.7.0)
hpricot (0.8.2, 0.6.164)
json_pure (1.2.3)
libxml-ruby (1.1.3, 1.1.2)
mongrel (1.1.5)
needle (1.3.0)
net-scp (1.0.2, 1.0.1)
net-sftp (2.0.4, 2.0.2, 2.0.1, 1.1.1)
net-ssh (2.0.21, 2.0.15, 2.0.11, 2.0.4, 1.1.4)
net-ssh-gateway (1.0.1, 1.0.0)
rack (1.1.0, 1.0.1)
rails (2.3.5, 2.2.2, 1.2.6)
rake (0.8.7, 0.8.4, 0.8.3, 0.8.1)
RedCloth (4.2.3, 4.1.1)
rjb (1.2.0, 1.1.9, 1.1.6)
rspec (1.3.0, 1.2.8, 1.2.2, 1.1.5)
ruby-openid (2.1.7, 2.1.2)
ruby-yadis (0.3.4)
rubyforge (2.0.4, 1.0.5, 1.0.3, 1.0.0)
rubygems-update (1.3.5)
rubynode (0.1.5)
rubyzip (0.9.4, 0.9.1)
sqlite3-ruby (1.2.5, 1.2.4)
termios (0.9.4)
xml-simple (1.0.12, 1.0.11)
xmpp4r (0.5, 0.4)

Please note that there are some unused gems since I tried to downgrade rake
and rubygems-update to 1.3.5.  That didn't work either.

Anyone got an idea (JAVA_HOME is set, btw)?

TIA,
KlaasJan Elzinga

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message