buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antoine Toulme <antoine.tou...@gmail.com>
Subject Re: Buildr and Cucumber
Date Mon, 21 Jun 2010 21:54:21 GMT
It will load the highest version available.

Sent from my iPhone

On Jun 21, 2010, at 14:38, Duncan McGregor <duncan@oneeyedmen.com>  
wrote:

> OK, notwithstanding edits to this file making no difference, I'm  
> confused. If I specify >=1.4.0 will this load 1.4.0 or 1.4.3 for  
> preference?
>
> D
>
> On 21 Jun 2010, at 19:05, Alex Boisvert wrote:
>
>> The issue has to do with Gem initialization order...
>>
>> Easiest would probably to edit the gemspec to allow this  
>> combination.  (On
>> my system, it's located under /usr/lib/ruby/gems/1.8/gems/ 
>> buildr-1.4.0/;
>> your system may place gems elsewhere)
>>
>> Index: buildr.gemspec
>> ===================================================================
>> --- buildr.gemspec    (revision 954999)
>> +++ buildr.gemspec    (working copy)
>> @@ -48,12 +48,12 @@
>>
>>  # Tested against these dependencies.
>>  spec.add_dependency 'rake',                 '0.8.7'
>>  spec.add_dependency 'builder',              '2.1.2'
>>  spec.add_dependency 'net-ssh',              '2.0.15'
>>  spec.add_dependency 'net-sftp',             '2.0.2'
>>  spec.add_dependency 'rubyzip',              '0.9.1'
>>  spec.add_dependency 'highline',             '1.5.1'
>> -  spec.add_dependency 'json_pure',            '1.4.0'
>> +  spec.add_dependency 'json_pure',            '>= 1.4.0'
>>  spec.add_dependency 'rubyforge',            '2.0.3'
>>  spec.add_dependency 'hoe',                  '2.3.3'
>>  spec.add_dependency 'rjb',                  '1.2.5' if  
>> spec.platform.to_s
>> == 'ruby'
>>
>> alex
>

Mime
View raw message