buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Maas <pfmm...@gmail.com>
Subject Re: issue packaging jars
Date Tue, 15 Jun 2010 21:08:09 GMT
Cool!

On Jun 15, 2010, at 10:38 PM, Antoine Toulme wrote:

> Fixed over lunch. Issuing RC5...
> 
> On Tue, Jun 15, 2010 at 13:06, Antoine Toulme <antoine@lunar-ocean.com> wrote:
> The fix for BUILDR-447 must have triggered the problem. I'm looking into it.
> 
> 
> On Tue, Jun 15, 2010 at 13:03, Peter Maas <pfmmaas@gmail.com> wrote:
> Btw,
> 
> the problem is not present in RC3, just verified that.
> 
> On Jun 15, 2010, at 9:54 PM, Peter Maas wrote:
> 
> > Okay, thanks for the quick response!
> >
> >
> > On Jun 15, 2010, at 9:04 PM, Antoine Toulme wrote:
> >
> >> Filed https://issues.apache.org/jira/browse/BUILDR-457 and assigned to me.
> >>
> >>
> >> On Tue, Jun 15, 2010 at 11:35, Alex Boisvert <alex.boisvert@gmail.com>wrote:
> >>
> >>> There seems to be a bug with Buildr adding a file named "." in the jar.
> >>>
> >>> With trunk,
> >>>
> >>> boisvert@smudge:~/tmp/buildr-jar$ jar tvf target/buildr-jar-0.1.jar
> >>> 533 Tue Jun 15 11:32:20 PDT 2010 .
> >>> 533 Tue Jun 15 11:32:20 PDT 2010 HelloWord.class
> >>>   0 Tue Jun 15 11:32:20 PDT 2010 META-INF/
> >>> 131 Tue Jun 15 11:32:20 PDT 2010 META-INF/MANIFEST.MF
> >>>
> >>> With Buildr 1.3.5,
> >>>
> >>> boisvert@smudge:~/tmp/buildr-jar$ jar tvf target/buildr-jar-0.1.jar
> >>> 533 Tue Jun 15 11:33:20 PDT 2010 HelloWord.class
> >>>   0 Tue Jun 15 11:33:20 PDT 2010 META-INF/
> >>> 139 Tue Jun 15 11:33:20 PDT 2010 META-INF/MANIFEST.MF
> >>>
> >>> Seems like a show-stopper for the latest RC.
> >>>
> >>> alex
> >>>
> >>>
> >>> On Tue, Jun 15, 2010 at 11:19 AM, Peter Maas <pfmmaas@gmail.com> wrote:
> >>>
> >>>> All,
> >>>>
> >>>> I'm running buildr from a github clone (made today) and have the
> >>> following
> >>>> problem:
> >>>>
> >>>> If I use the package target, or when doing a custom package the created
> >>> jar
> >>>> file can not be extracted:
> >>>>
> >>>> Peter-Maass-MacBook-Pro:target peter$ jar -tvf
> >>>> dataservices-httpsession-1.jar
> >>>> 1826 Tue Jun 15 20:12:34 CEST 2010 .
> >>>>   0 Tue Jun 15 20:12:34 CEST 2010 META-INF/
> >>>> 193 Tue Jun 15 20:12:34 CEST 2010 META-INF/MANIFEST.MF
> >>>>   0 Tue Jun 15 20:12:34 CEST 2010 META-INF/spring/1
> >>>> 1826 Tue Jun 15 20:12:34 CEST 2010 META-INF/spring/pu.xml
> >>>> Peter-Maass-MacBook-Pro:target peter$ jar -xvf
> >>>> dataservices-httpsession-1.jar
> >>>> created: META-INF/
> >>>> inflated: META-INF/MANIFEST.MF
> >>>> java.io.FileNotFoundException: . (No such file or directory)
> >>>>      at java.io.FileOutputStream.open(Native Method)
> >>>>      at java.io.FileOutputStream.<init>(FileOutputStream.java:179)
> >>>>      at java.io.FileOutputStream.<init>(FileOutputStream.java:131)
> >>>>      at sun.tools.jar.Main.copy(Main.java:783)
> >>>>      at sun.tools.jar.Main.extractFile(Main.java:933)
> >>>>      at sun.tools.jar.Main.extract(Main.java:852)
> >>>>      at sun.tools.jar.Main.run(Main.java:242)
> >>>>      at sun.tools.jar.Main.main(Main.java:1149)
> >>>>
> >>>>
> >>>>
> >>>> This happens with every jar created by buildr.
> >>>>
> >>>> Environment:
> >>>>
> >>>> * OSX 10.6.3
> >>>> * Ruby: ruby 1.8.7 (2009-06-08 patchlevel 173) [universal-darwin10.0]
> >>>> * java version "1.6.0_20"
> >>>> Java(TM) SE Runtime Environment (build 1.6.0_20-b02-279-10M3065)
> >>>> Java HotSpot(TM) 64-Bit Server VM (build 16.3-b01-279, mixed mode)
> >>>> * list of installed gems attached
> >>>>
> >>>> If I create a jar with the jar command supplied by the install JDK I
can
> >>>> unpack it without any problems.
> >>>>
> >>>> Any suggestions?
> >>>>
> >>>> -P
> >>>>
> >>>>
> >>>>
> >>>>
> >>>>
> >>>>
> >>>>
> >>>>
> >>>>
> >>>>
> >>>>
> >>>
> >
> 
> 
> 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message