buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rhett Sutphin <rh...@detailedbalance.net>
Subject Re: buildr 1.4 packaging problem?
Date Thu, 01 Jul 2010 15:38:10 GMT
Hi,

On Jul 1, 2010, at 10:26 AM, Alex Boisvert wrote:

> Hi Kristof,
> 
> Yes, Ruby 1.9.x compatibility is a work in progress.  Thanks for reporting.
> If you feel like spending some time to fix it (it's likely to be a trivial
> fix) it would be appreciated.

I posted on the ticket, but I'll repeat it here since it's a curious problem:  it seems like
the issue is that under 1.9.1, rubygems is activating the most recent installed version of
rubyzip (0.9.4 in Kristof's case), not the version (0.9.1) that buildr requests.  

Bug #3140[1] in MRI's issue tracker seems like it is related.  I don't think this can be fixed
in buildr.

Rhett

[1]: http://redmine.ruby-lang.org/issues/show/3140

> 
> alex
> 
> 
> On Thu, Jul 1, 2010 at 6:46 AM, Kristof Jozsa <kristof.jozsa@gmail.com>wrote:
> 
>> Hi guys,
>> 
>> I just discovered buildr already has transitive dependency handling
>> and that sounded way too cool to miss it.. Unfortunately I'd run into
>> a packaging problem in a few minutes. I _guess_ it's a compatibility
>> issue.. but sure you know better than me.
>> 
>> The issue is shown here:
>> https://issues.apache.org/jira/browse/BUILDR-462 and it happens on
>> arch linux x64 using ruby 1.9.1 and the latest buildr gem. If you have
>> a quick fix or any workarounds for now, I'd be happy to try it out.
>> 
>> thanks a lot,
>> K
>> 


Mime
View raw message