buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Khristian Alexander Schönrock <>
Subject Re: Install Woes on Windows 7 64bit with RubyInstaller for Windows
Date Mon, 20 Sep 2010 15:14:31 GMT
  I ran into the same problem some time ago. I solved it by downloading 
a rjb gem which included the native extension (1.2.5, I think) and 
edited the version number to the one buildr wanted (1.2.6). Installed 
the hacked rjb gem, then buildr, without problems.

Em 20/09/2010 12:09, Samuel Ecko escreveu:
> Just wanted to report my installation issues with Buildr on my Windows
> 7 64bit machine and how I worked around them.
> I am new to Buildr and Ruby, so I'm not sure if the problems are
> specific to my computer and/or OS or not. I tried to follow the
> install instructions from the Buildr website
> ( and downloaded
> RubyInstaller for Windows 1.8.7 (and rolled back to 1.8.6 when I ran
> into troubles).
> To me it seems that Buildr 1.4.1 requires version 1.2.5 of rjb
> (Ruby-Java-Bridge), but the standard gems repository does not have a
> pre-compiled package for 1.2.5, only for the latest version 1.2.8. See
> This is why installing Buildr
> with the platform --platform=mswin32 switch will trigger a compile of
> rjb which subsequently fails without a C compiler being present on the
> system.
> The RubyInstaller for Windows cannot compile Ruby gems by default, and
> fails with a rather obscure message pointing in the wrong direction,
> more precisely the check for jni.h in the JAVA_HOME / include
> directory fails and a Ruby noob like me would assume a problem with
> the Java install or some permission problem. Google did not really
> help (quickly).
> What did the trick for me was to install the 'DevKit' from the
> RubyInstaller for W. website. Version 4.5.0 failed with a different
> error message ('long long long is too long'), but with 3.4.5 I was
> finally able to compile rjb 1.2.5 and install Buildr 1.4.1.
> Other steps I took that might or might not have affected the outcome
> of the install
> - use 32bit JDK instead of 64bit
> - set JAVA_HOME to 8.3 character file name, e.g. c:\progra~2\java\jdk1.6.0_21
> - install Ruby into a directory path that does not contain spaces
> Hope my email will help other Buildr/Ruby noobs and/or maybe help
> solve the dependency problem (if there actually is one ;))
> Samuel Ecko

View raw message