buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Petrovic <mspetro...@gmail.com>
Subject Re: buildr buffering console output during test phase?
Date Mon, 06 Sep 2010 16:37:26 GMT
I added a comment to issue 161.   I see in my Jira view no way to reopen the issue - sorry.

On Sep 6, 2010, at 9:25 AM, Antoine Toulme wrote:

> No idea. Can you open a bug about it or reopen BUILDR-161 with your test case from earlier
?
> 
> On Mon, Sep 6, 2010 at 08:58, Mark Petrovic <mspetrovic@gmail.com> wrote:
> I'm using buildr to wrap several existing projects, one of which has some JUnit 3 tests
stuffed way down in an obscure directory.  Could this be triggering the 'override' message
below?  Beyond that, there is no other JUnit 3 code anywhere.
> 
> 
> On Sep 6, 2010, at 8:20 AM, Antoine Toulme wrote:
> 
> > Not sure, --trace probably makes the application more verbose and gives back
> > output as you go.
> > It might be a setting in the ant runner for junit.
> >
> > On Sun, Sep 5, 2010 at 20:41, Mark Petrovic <mspetrovic@gmail.com> wrote:
> >
> >> My experience with buildr is limited, but I don't remember it buffering
> >> console output during the test phase.
> >>
> >> If I do
> >>
> >> $ buildr clean test
> >>
> >> the console output pauses here
> >>
> >> Running tests in parent:vzservice:vzserver
> >> Trying to override old definition of datatype junit
> >>   [junit] Testsuite: org.foo.rest.TestIngest
> >> <pause>
> >>
> >> whereupon when the tests (of the JUnit4 variety) finish, I get the full
> >> console output in one large dump.
> >>
> >> But if I do
> >>
> >> $ buildr --trace clean test
> >>
> >> I can see the individual tests being invoked as they execute.
> >>
> >> Is this buffered output normal during the test phase?
> >>
> >>
> >>
> >> --
> >> Mark Petrovic
> >>
> >>
> >>
> 
> 
> --
> Mark Petrovic
> 
> 
> 


--
Mark Petrovic



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message