buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rhett Sutphin <>
Subject Re: Cannot create Java JVM on Mac
Date Tue, 16 Nov 2010 19:25:47 GMT

Rjb 1.3.3 fixes this issue for me.  I've run buildr's specs using rjb 1.3.3 and the all pass
except for three (which I believe are expected to fail and at any rate seem unrelated).  Would
it be possible to get a new version of buildr which depends on rjb 1.3.3 instead of 1.2.5?


On Nov 15, 2010, at 2:15 PM, Ed Smiley wrote:

> Hi Rhett,
> I took the issue down to the simplest possible case and attached the trace
> (and buildfile, although there is nothing special about it).
> --Ed
> On Mon, Nov 15, 2010 at 11:12 AM, Rhett Sutphin
> <>wrote:
>> Hi Ed,
>> On Nov 15, 2010, at 12:27 PM, Ed Smiley wrote:
>>> Going back to my project, even if I tear out all the direct invocations
>> of
>>> the Java VM, I cannot compile Java now.
>>> This is a show stopper for me.  Any word on a fix?
>> I'm running into this now.  Something I have discovered in trying to figure
>> out a workaround for the current buildr is that, while
>> `/usr/libexec/java_home` is supposed to be the supported way to locate a JVM
>> on OS X, there doesn't seem to be a way to get it to yield the path to a JDK
>> instead of a JRE.  I found on my system that I need to set JAVA_HOME like so
>> to get rjb 1.2.5 to compile:
>> export
>> JAVA_HOME='/Library/Java/JavaVirtualMachines/1.6.0_22-b04-307.jdk/Contents/Home'
>> However, creating a JVM still doesn't work.  Allegedly upgrading to
>> rjb-1.3.2 will fix that problem; I've tried that out with buildr trunk
>> without success.  I've written up a ticket[1] and will update it if I find a
>> solution.
>> Rhett
>> [1]:

View raw message