buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rhett Sutphin <rh...@detailedbalance.net>
Subject Re: Cannot create Java JVM on Mac
Date Mon, 15 Nov 2010 19:12:58 GMT
Hi Ed,

On Nov 15, 2010, at 12:27 PM, Ed Smiley wrote:

> Going back to my project, even if I tear out all the direct invocations of
> the Java VM, I cannot compile Java now.
> This is a show stopper for me.  Any word on a fix?

I'm running into this now.  Something I have discovered in trying to figure out a workaround
for the current buildr is that, while `/usr/libexec/java_home` is supposed to be the supported
way to locate a JVM on OS X, there doesn't seem to be a way to get it to yield the path to
a JDK instead of a JRE.  I found on my system that I need to set JAVA_HOME like so to get
rjb 1.2.5 to compile:

export JAVA_HOME='/Library/Java/JavaVirtualMachines/1.6.0_22-b04-307.jdk/Contents/Home'

However, creating a JVM still doesn't work.  Allegedly upgrading to rjb-1.3.2 will fix that
problem; I've tried that out with buildr trunk without success.  I've written up a ticket[1]
and will update it if I find a solution.

Rhett

[1]: https://issues.apache.org/jira/browse/BUILDR-549
Mime
View raw message