buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Donald <pe...@realityforge.org>
Subject Re: VOTE: Remove JtestR support
Date Tue, 21 Jun 2011 21:47:19 GMT
On Wed, Jun 22, 2011 at 4:38 AM, Alex Boisvert <alex.boisvert@gmail.com> wrote:
> As discussed earlier, JtestR integration has become a maintenance burden
> that I can no longer sustain in my limited open-source time.  In case you
> haven't followed, the main issue is that JtestR is only compatible with a
> restricted set of dependencies (notably rspec 1.3.0 and only up to JRuby
> 1.5.4) which conflicts with buildr's own set of dependencies.   There is no
> plan <http://markmail.org/message/ifjbbh6ppyufvxmi> to upgrade JtestR to
> rspec 2.0 and combined with the very few users actually relying on JtestR
> means the feature doesn't support its own weight.
>
> VOTE
> [ ] +1 Agree to remove JtestR support
> [ ] +/- 0  No opinion
> [ ] -1 Disagree to remove JTestR support (and propose solution to JtestR
> maintenance)

+1

-- 
Cheers,

Peter Donald

Mime
View raw message