buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Damian Monogue <demon...@gmail.com>
Subject Re: Windows installation woes
Date Fri, 09 Sep 2011 18:37:13 GMT
Ok, so I downloaded the all in one, and once I realized I still had to do a
'gem install buildr' with the jruby implementation provided it went much
more smoothly. Now to do some testing to be sure it works the same using
jruby on windows as it does using MRI 1.8.7p352 on the linux build node.

Thanks, Antoine. You're a lifesaver.

On Thu, Sep 8, 2011 at 9:30 PM, Antoine Toulme <antoine@lunar-ocean.com>wrote:

> Did you try the all-in-one bundle based on jruby you can download from
> rubyforge ?
>
> It doesn't require any installation besides having java.
>
> Please take a look:
>
> http://rubyforge.org/frs/?group_id=3180
>
> On Wed, Sep 7, 2011 at 12:06, Damian Monogue <demonnic@gmail.com> wrote:
>
> > Hello again!
> >
> > Well, I got that project working well finally, but now I've got to get
> the
> > developers working with the new build tool, and they primarily use
> windows
> > workstations. We're all running into some issues installing it on
> windows,
> > however. I am hoping someone has a solution to this one. It fails while
> > generation the documentation for builder-2.0.2 (which I know isn't the
> same
> > as buildr). Since it was on the documentation step, I figured I'd go
> ahead
> > and try to run buildr, but that gives me an error regarding not being
> able
> > to find buildr <>= 0 amongst my installed gems.
> >
> > Any help would be appreciated. Here is the output of the install and
> > attempt
> > to run it. Before running the following, I uninstalled all local gems and
> > started from scratch.
> >
> > C:\Documents and Settings\dmonogue.CPEX>gem install buildr --platform
> > mswin32
> > Fetching: rake-0.8.7.gem (100%)
> > Fetching: builder-2.1.2.gem (100%)
> > WARNING: builder-2.1.2 has an invalid nil value for @cert_chain
> > Fetching: net-ssh-2.0.23.gem (100%)
> > Fetching: net-sftp-2.0.4.gem (100%)
> > Fetching: rubyzip-0.9.4.gem (100%)
> > Fetching: highline-1.5.1.gem (100%)
> > Fetching: json_pure-1.4.3.gem (100%)
> > Fetching: rubyforge-2.0.3.gem (100%)
> > Fetching: hoe-2.3.3.gem (100%)
> > Fetching: rjb-1.3.2-x86-mswin32-60.gem (100%)
> > Fetching: atoulme-Antwrap-0.7.1.gem (100%)
> > Fetching: diff-lcs-1.1.2.gem (100%)
> > Fetching: rspec-expectations-2.1.0.gem (100%)
> > Fetching: rspec-mocks-2.1.0.gem (100%)
> > Fetching: rspec-core-2.1.0.gem (100%)
> > **************************************************
> >
> >  Thank you for installing rspec-core-2.1.0
> >
> >  Please be sure to look at the upgrade instructions to see what might
> have
> >  changed since the last release:
> >
> >  http://github.com/rspec/rspec-core/blob/master/Upgrade.markdown
> >
> > **************************************************
> > Fetching: rspec-2.1.0.gem (100%)
> > Fetching: xml-simple-1.0.12.gem (100%)
> > Fetching: minitar-0.5.3.gem (100%)
> > Fetching: buildr-1.4.6-x86-mswin32.gem (100%)
> > To get started run buildr --help
> > Successfully installed rake-0.8.7
> > Successfully installed builder-2.1.2
> > Successfully installed net-ssh-2.0.23
> > Successfully installed net-sftp-2.0.4
> > Successfully installed rubyzip-0.9.4
> > Successfully installed highline-1.5.1
> > Successfully installed json_pure-1.4.3
> > Successfully installed rubyforge-2.0.3
> > Successfully installed hoe-2.3.3
> > Successfully installed rjb-1.3.2-x86-mswin32-60
> > Successfully installed atoulme-Antwrap-0.7.1
> > Successfully installed diff-lcs-1.1.2
> > Successfully installed rspec-expectations-2.1.0
> > Successfully installed rspec-mocks-2.1.0
> > Successfully installed rspec-core-2.1.0
> > Successfully installed rspec-2.1.0
> > Successfully installed xml-simple-1.0.12
> > Successfully installed minitar-0.5.3
> > Successfully installed buildr-1.4.6-x86-mswin32
> > 19 gems installed
> > Installing ri documentation for rake-0.8.7...
> > Installing ri documentation for builder-2.1.2...
> > ERROR:  While generating documentation for builder-2.1.2
> > ... MESSAGE:   Unhandled special: Special: type=17, text="<!-- HI -->"
> > ... RDOC args: --ri --op
> C:/Ruby187/lib/ruby/gems/1.8/doc/builder-2.1.2/ri
> > --tit
> > le Builder -- Easy XML Building --main README --line-numbers lib CHANGES
> > Rakefil
> > e README doc/releases/builder-1.2.4.rdoc doc/releases/builder-2.0.0.rdoc
> > doc/rel
> > eases/builder-2.1.1.rdoc --title builder-2.1.2 Documentation --quiet
> >
> > C:\Documents and Settings\dmonogue.CPEX>buildr --version
> > C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/dependency.rb:247:in
> `to_specs':
> > Coul
> > d not find buildr (>= 0) amongst [atoulme-Antwrap-0.7.1, builder-2.1.2,
> > buildr-1
> > .4.6-x86-mswin32, diff-lcs-1.1.2, highline-1.5.1, hoe-2.3.3,
> > json_pure-1.4.3, mi
> > nitar-0.5.3, net-sftp-2.0.4, net-ssh-2.0.23, rake-0.8.7,
> > rjb-1.3.2-x86-mswin32-6
> > 0, rspec-2.1.0, rspec-core-2.1.0, rspec-expectations-2.1.0,
> > rspec-mocks-2.1.0, r
> > ubyforge-2.0.3, rubygems-update-1.8.10, rubyzip-0.9.4, xml-simple-1.0.12]
> > (Gem::
> > LoadError)
> >        from
> C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/dependency.rb:256:in
> > `to
> > _spec'
> >        from C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems.rb:1210:in `gem'
> >        from C:/Ruby187/bin/buildr:18
> >
> > C:\Documents and Settings\dmonogue.CPEX>
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message