buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rhett Sutphin <>
Subject Re: path_to can't resolve space in path
Date Mon, 12 Sep 2011 16:18:50 GMT
Hi Allen,

On Sep 12, 2011, at 11:00 AM, Allen Riddle wrote:

> When I run my project locally, there is no space in the fully qualified path
> to the following folder (~/projects/myproject is the home of the project):
> _('target/classes/com/rubinix/communication/messages')
> However, when the project is built on our build server, our ops guy set it
> up as a sub directory in our existing build infrastructure, and a space is
> in the path (/existing/builds/path with_space/myproject), the aliased call
> to path_to returns everything after the space as it's result.

Are you sure the problem is with path_to? Have you tried checking out the code in a directory
with a space on your workstation to see if you can reproduce it locally? I tried to reproduce
it using the description you're giving and had no luck:

$ buildr --version
Buildr 1.4.6
$ pwd
/tmp/with space/foo
$ cat buildfile 
define 'foo' do
  define 'bar' do
    puts _('target/baz').inspect
$ buildr help:projects
(in /private/tmp/with space/foo, development)
"/private/tmp/with space/foo/bar/target/baz"
Completed in 0.000s


> On Mon, Sep 12, 2011 at 10:50 AM, Rhett Sutphin
> <>wrote:
>> Hi Allen,
>> On Sep 12, 2011, at 10:46 AM, Allen Riddle wrote:
>>> All,
>>> Is there a way to get the path_to method to resolve a path that has a
>> space
>>> in it's name?  When I evaluate it with a space in the path, it returns
>>> everything after the space.  Example:
>>> /some/path with_space/project evaultes to with_space/project
>>> Any thoughts?  Thanks.
>> Can you show us an actual call that has this behavior?
>> Thanks,
>> Rhett

View raw message