buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From S Ahmed <sahmed1...@gmail.com>
Subject buildr error: cannot load file
Date Mon, 16 Apr 2012 15:50:20 GMT
Very new to buildr.

Trying to build this application and I am getting the following error:

~/dev/testapp>buildr test=no clean package --trace
/Users/me/.rvm/gems/ruby-1.9.3-p0@railstesting/gems/rake-0.8.7/lib/rake/alt_system.rb:32:
Use RbConfig instead of obsolete and deprecated Config.
/Users/me/.rvm/rubies/ruby-1.9.3-p0/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require': iconv will be deprecated in the future, use String#encode
instead.
(in /Users/me/dev/sources/java/sewer, development)
Buildr aborted!
LoadError : cannot load such file -- buildfile_libraries.rb
/Users/me/.rvm/rubies/ruby-1.9.3-p0/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
/Users/me/.rvm/rubies/ruby-1.9.3-p0/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
/Users/me/dev/sources/java/sewer/buildfile:14:in `<top (required)>'
/Users/me/.rvm/gems/ruby-1.9.3-p0@railstesting/gems/buildr-1.4.6/lib/buildr/core/application.rb:424:in
`load'
/Users/me/.rvm/gems/ruby-1.9.3-p0@railstesting/gems/buildr-1.4.6/lib/buildr/core/application.rb:424:in
`raw_load_buildfile'
/Users/me/.rvm/gems/ruby-1.9.3-p0@railstesting/gems/buildr-1.4.6/lib/buildr/core/application.rb:232:in
`block in load_buildfile'
/Users/me/.rvm/gems/ruby-1.9.3-p0@railstesting/gems/buildr-1.4.6/lib/buildr/core/application.rb:535:in
`standard_exception_handling'
/Users/me/.rvm/gems/ruby-1.9.3-p0@railstesting/gems/buildr-1.4.6/lib/buildr/core/application.rb:227:in
`load_buildfile'
/Users/me/.rvm/gems/ruby-1.9.3-p0@railstesting/gems/buildr-1.4.6/lib/buildr/core/application.rb:137:in
`block in run'
/Users/me/.rvm/gems/ruby-1.9.3-p0@railstesting/gems/buildr-1.4.6/lib/buildr/core/application.rb:535:in
`standard_exception_handling'
/Users/me/.rvm/gems/ruby-1.9.3-p0@railstesting/gems/buildr-1.4.6/lib/buildr/core/application.rb:135:in
`run'
/Users/me/.rvm/gems/ruby-1.9.3-p0@railstesting/gems/buildr-1.4.6/bin/buildr:19:in
`<top (required)>'
/Users/me/.rvm/gems/ruby-1.9.3-p0@railstesting/bin/buildr:19:in `load'
/Users/me/.rvm/gems/ruby-1.9.3-p0@railstesting/bin/buildr:19:in `<main>'


What could the issue be?

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message