buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Niklaus Giger <niklaus.gi...@member.fsf.org>
Subject Re: Generated plugin contains files with wrong path (buildr4osgi)
Date Sat, 06 Oct 2012 01:24:49 GMT
Hi

I think I now the region where bug lies. I think buildr4osgi assumes in 
lib/buildr4osgi/osgi/packaging.rb (around line 280) that the first entry in 
the Bundle-ClassPath is a '.'. Which is not always the case in my projects.

But I don't yet understand why buildr4osgi reads only the first entry and not 
more. 

Best regards

Niklaus


> Hi
> 
> I'm getting closer the following diff makes the error disapper:
> > diff --git a/ch.elexis.mail/META-INF/MANIFEST.MF
> > b/ch.elexis.mail/META-INF/MANIFEST.MF ---
> > a/ch.elexis.mail/META-INF/MANIFEST.MF
> > +++ b/ch.elexis.mail/META-INF/MANIFEST.MF
> > @@ -14,9 +14,9 @@
> > 
> >   org.eclipse.ui.forms,
> >   ch.rgw.utility,
> >   ch.elexis;bundle-version="2.1.0"
> > 
> > -Bundle-ClassPath: activation.jar,
> > +Bundle-ClassPath: .,
> > 
> >   mail.jar,
> > 
> > - .
> > + activation.jar
> > 
> >  Export-Package: ch.elexis.mail,
> >  
> >   com.sun.activation.registries,
> >   com.sun.activation.viewers,
> 
> But running the trace with and without the patch did not show and
> interesting diff.
> 
> Best regards
> 
> Niklaus
> 
> > Hi
> > 
> > Not very successful at creating a really smallish project.
> > 
> > Size is now 4 projects, 5,7 MB java code, 1 extension of mine. Time to
> > run less than a minute.
> > 
> > I will try tomorrow or after my vacation to hunt it down even further.
> > 
> > Best regards
> > 
> > > Sorry, no idea why that's happening.  If you can set up a smallish
> > > project that I could test on, I'm sure I could track this down.
> > > 
> > > alex
> > > 
> > > On Fri, Oct 5, 2012 at 3:12 PM, Niklaus Giger
> > > 
> > > <niklaus.giger@member.fsf.org>wrote:
> > > > Hi
> > > > 
> > > > I have a fairly large project (150 Eclipse-Plugins) where I have
> > > > about 3 errors, which all look similars: instead of having a
> > > > jar-file and some
> > > > 
> > > > compiled classes the generated package(:plugin) looks like this:
> > > > > " zip.vim version v25
> > > > > " Browsing zipfile
> > > > 
> > > > /opt/elexis-problem/elexis-base/ch.elexis.mail/target/ch.elexis.mail-
> > > > 2. 0. 1
> > > > 
> > > > > .20121005.jar " Select a file with cursor and press ENTER
> > > > > 
> > > > > META-INF/
> > > > > META-INF/MANIFEST.MF
> > > > > META-INF/MANIFEST.MF.orig
> > > > > activation.jar/
> > > > > activation.jar/ch/
> > > > > activation.jar/ch/elexis/
> > > > > activation.jar/ch/elexis/mail/
> > > > > activation.jar/ch/elexis/mail/Activator.class
> > > > > activation.jar/ch/elexis/mail/Mailbox.class
> > > > > activation.jar/ch/elexis/mail/Mailer.class
> > > > > activation.jar/ch/elexis/mail/Messages.class
> > > > > activation.jar/ch/elexis/mail/PreferenceConstants.class
> > > > > activation.jar/ch/elexis/mail/Preferences.class
> > > > > activation.jar/ch/elexis/mail/QFADialog.class
> > > > > activation.jar/ch/elexis/mail/SMTPAuthenticator.class
> > > > > activation.jar/ch/elexis/mail/SendQFA.class
> > > > > ch/
> > > > > ch/elexis/
> > > > > ch/elexis/mail/
> > > > > ch/elexis/mail/messages.properties
> > > > > ch/elexis/mail/messages_en.properties
> > > > > ch/elexis/mail/messages_fr.properties
> > > > > mail.jar
> > > > > medelexis.xml
> > > > > plugin.xml
> > > > 
> > > > The corresponding fragment looks like this in the buildfile:
> > > >   define 'ch.elexis.mail', :base_dir=>'elexis-base/ch.elexis.mail',
> > > >   
> > > >          :version=> '2.0.1' do
> > > >     
> > > >     check package(:plugin), 'plugin should include 2 local jars' do
> > > >     
> > > >       it.should contain('activation.jar')
> > > >       it.should contain('mail.jar')
> > > >     
> > > >     end
> > > >     package(:plugin).include(_('activation.jar'))
> > > >     package(:plugin).include(_('mail.jar'))
> > > >     dependencies << projects('ch.rgw.utility', 'ch.elexis')
> > > >   
> > > >   end
> > > > 
> > > > If I rename my source folder in order to avoid compilation, the jars
> > > > get packed correctly. Any ideas why 4 of about 50 plugin which
> > > > contain jars don't
> > > > work? How do I debug this? Using --trace I just see
> > > > 
> > > > 
> > > > Packaging elexis-ch.elexis.mail-2.0.1.20121005.jar
> > > > <..>
> > > > ** Invoke /opt/elexis-problem/elexis-
> > > > base/ch.elexis.mail/target/ch.elexis.mail-2.0.1.20121005.jar
> > > > (first_time) Adding medelexis.xml
> > > > Adding activation.jar
> > > > Adding mail.jar
> > > > Adding META-INF/MANIFEST.MF.orig
> > > > Adding META-INF/MANIFEST.MF
> > > > Adding META-INF
> > > > Adding activation.jar/ch
> > > > Adding activation.jar/ch/elexis
> > > > Adding activation.jar/ch/elexis/mail
> > > > Adding activation.jar/ch/elexis/mail/SMTPAuthenticator.class
> > > > Adding activation.jar/ch/elexis/mail/QFADialog.class
> > > > <..>
> > > > 
> > > > Thanks in advance for any advice.
> > > > 
> > > > Best regards
> > > > 
> > > > --
> > > > Niklaus Giger
-- 
Niklaus Giger
Wieshoschet 6
CH-8753 Mollis
+41  (0)55 612 20 54 P
+41  (0)77 473 02 59 Mobil

Mime
  • Unnamed multipart/alternative (inline, 7-Bit, 0 bytes)
View raw message