buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Tillotson <slatem...@yahoo.co.uk>
Subject Re: Artifacts Download - Permission Denied
Date Tue, 03 Sep 2013 09:45:28 GMT
+1 for this issue

A recent change (same code working 1 month ago) somewhere looks to have broken artifact download. 

I was trying a number of mirrors, and it fails across the whole set. I've no tried 1.9.2 yet
but tcpdump'd the request

GET /maven2/org/apache/accumulo/accumulo-core/1.4.3/accumulo-core-1.4.3.jar HTTP/1.1
Host: uk.maven.org
Connection: close
Accept: */*

HTTP/1.1 403 Denied Access
Server: Varnish
Retry-After: 0
Content-Type: text/html; charset=utf-8
Content-Length: 401
Accept-Ranges: bytes
Date: Tue, 03 Sep 2013 08:40:51 GMT
Via: 1.1 varnish
Age: 0
Connection: close
X-Served-By: cache-lo83-LHR
X-Cache: MISS
X-Cache-Hits: 0

I suspect either "Connection: close" or lack of "User Agent"

Succesfull wget header 

GET /maven2/org/apache/accumulo/accumulo-core/1.4.3/accumulo-core-1.4.3.jar HTTP/1.1
User-Agent: Wget/1.13.4 (linux-gnu)
Accept: */*
Host: uk.maven.org
Connection: Keep-Alive



________________________________
 From: Chris Adams <chris@edatasource.com>
To: users@buildr.apache.org 
Sent: Tuesday, 27 August 2013, 21:59
Subject: Re: Artifacts Download - Permission Denied
 

That's probably it. I'm using Ruby 1.8.7 on MacOS. I'll try upgrading to 1.9.2 to see if that
resolves the problem. Crazily enough, this is a fairly recent issue… wonder what Maven Central
changed…
Thanks for the idea about upgrading Ruby; I wasn't even thinking in that direction.

- Chris


On Aug 27, 2013, at 3:57 PM, Alex Boisvert <alex.boisvert@gmail.com> wrote:

> Weird.  I can reproduce with standard Ruby 1.8.7 ... but when I use 1.9.2
> or JRuby 1.7.1 it works ... I'm suspecting some issue with the underlying
> HTTP library.
> 
> 
> On Tue, Aug 27, 2013 at 12:01 PM, Chris Adams <chris@edatasource.com> wrote:
> 
>> Hello,
>> 
>> While trying to download artifacts from the central Maven repo, I get the
>> following error:
>> Failed to download
>> http://repo1.maven.org/maven2/org/elasticsearch/elasticsearch/0.90.2/elasticsearch-0.90.2.jar:
>> Denied Access
>> 
>> But, if I copy/paste the URL into a browser, the jar file downloads fine.
>> 
>> Any ideas?
>> 
>> Thanks.
>> 
>> - Chris
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message