buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Philippe Caruana ...@target2sell.com>
Subject junit conflict in idea
Date Mon, 03 Mar 2014 13:16:24 GMT
Hi,

I'm using Buildr 1.4.15 and I have junit conflict in my idea files : I
see two version of junit :
- 4.8.2 (that "ships" with buildr)
- 4.11 (last version I use)

My buildfile looks like this:

JUNIT = 'junit:junit:jar:4.11'
  define 'common' do
    compile.with LOG4J
    test.compile.with JUNIT
    package :jar
  end


My project iml file looks like this :
    <orderEntry type="module-library" exported="">
      <library>
        <CLASSES>
          <root url="jar://$M2_REPO$/junit/junit/4.8.2/junit-4.8.2.jar!/" />
        </CLASSES>
        <JAVADOC />
        <SOURCES>
          <root
url="jar://$M2_REPO$/junit/junit/4.8.2/junit-4.8.2-sources.jar!/" />


        </SOURCES>
      </library>
    </orderEntry>

    <orderEntry type="module-library" scope="TEST">
      <library>
        <CLASSES>
          <root url="jar://$M2_REPO$/junit/junit/4.11/junit-4.11.jar!/"
/>

        </CLASSES>
        <JAVADOC />
        <SOURCES>
          <root
url="jar://$M2_REPO$/junit/junit/4.11/junit-4.11-sources.jar!/" />
        </SOURCES>
      </library>
    </orderEntry>



I have two questions :
- how can I tell buildr to ignore junit 4.8.2 version when I want
another one (hene 4.11) ?
- maybe the 4.11 shound be junit default version ?

Thanks
-- 
Jean-Philippe Caruana - jp@target2sell.com
http://www.barreverte.fr

Mime
View raw message