buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sathwik B P <sathwik...@gmail.com>
Subject Re: RuntimeError : Unsatisfied dependency xmlbeans -> org.apache.xmlbeans:xmlbeans:jar:2.3.0 -> [">", #<Gem::Version "2.6.0">] not satisfied by 2.6.0
Date Tue, 22 Jul 2014 19:47:00 GMT
Oops,

The patch works after upgrading to jruby 1.7.13 and buildr 1.4.19

https://builds.apache.org/job/ODE-trunk-jdk6/800/console

thanks,
sathwik


On Tue, Jul 22, 2014 at 11:57 PM, Sathwik B P <sathwik.bp@gmail.com> wrote:

> Hi Peter,
>
> Thanks for your response. I tried your patch on my local machine and the
> response is the same error.
>
> Now same error is occurring on apache build severs kindly refer
> https://builds.apache.org/job/ODE-trunk-jdk6/799/console
>
> regards,
> sathwik
>
>
> On Wed, Jun 18, 2014 at 5:07 PM, Peter Donald <peter@realityforge.org>
> wrote:
>
>> HI there,
>>
>> It seems to be a differences between jruby and other rubies or maybe
>> it has to do with differences in the rubygems implementation. I will
>> try and track down the exact cause. For the time being you should be
>> able to apply the following change.
>>
>> diff --git a/Rakefile b/Rakefile
>> index b93065f..c31c6c2 100644
>> --- a/Rakefile
>> +++ b/Rakefile
>> @@ -32,7 +32,7 @@ Buildr::Hibernate::REQUIRES[:xdoclet] =
>> Buildr.group("xdoclet", "xdoclet-xdoclet
>>   :under=>"xdoclet", :version=>"1.2.3") + ["xdoclet:xjavadoc:jar:1.1-j5"]
>>
>>  # XMLBeans addon must use the same version as we do.
>> -Buildr::XMLBeans::REQUIRES.xmlbeans = artifact(XMLBEANS).version
>> +Buildr::XMLBeans::REQUIRES.xmlbeans.version = artifact(XMLBEANS).version
>>
>>  # dirty workaround for BUILDR-541/BUILDR-508
>>  Java.classpath << Buildr::OpenJPA::REQUIRES
>>
>>
>>
>> On Sat, Jun 14, 2014 at 7:34 PM, Sathwik B P <sathwik.bp@gmail.com>
>> wrote:
>> > Hi Guys,
>> >
>> > Am encountering this error message when I am trying to build Apache ODE.
>> >
>> > RuntimeError : Unsatisfied dependency xmlbeans ->
>> > org.apache.xmlbeans:xmlbeans:jar:2.3.0 -> [">", #<Gem::Version "2.6.0">]
>> > not satisfied by 2.6.0
>> >
>> > We have xmlbeans dependency version as 2.6.0
>> > https://github.com/apache/ode/blob/master/Rakefile#L35
>> >
>> >
>> > Build environment details as follows,
>> >
>> > ~/apps/jruby-1.7.12/bin/jruby -S gem list
>> >
>> > *** LOCAL GEMS ***
>> >
>> > atoulme-Antwrap (0.7.4 java)
>> > bouncy-castle-java (1.5.0147)
>> > builder (3.2.2)
>> > buildr (1.4.17 java)
>> > bundler (1.6.2)
>> > diff-lcs (1.2.4)
>> > hoe (3.7.1)
>> > jruby-openssl (0.9.3, 0.8.10)
>> > jruby-pageant (1.1.1 java)
>> > json (1.8.0 java)
>> > json_pure (1.8.0)
>> > krypt (0.0.2.rc1)
>> > krypt-core (0.0.2.rc1 universal-java)
>> > krypt-provider-jdk (0.0.2.rc1)
>> > minitar (0.5.4)
>> > net-sftp (2.1.2)
>> > net-ssh (2.7.0)
>> > orderedhash (0.0.6)
>> > rake (10.1.0, 0.9.2.2)
>> > rdoc (4.0.1)
>> > rspec (2.14.1)
>> > rspec-core (2.14.5)
>> > rspec-expectations (2.14.3)
>> > rspec-mocks (2.14.3)
>> > rubyforge (2.0.4)
>> > rubyzip (0.9.9)
>> > xml-simple (1.1.2)
>> >
>> >
>> > I had to replace the line
>> > *ns.xmlbeans! 'org.apache.xmlbeans:xmlbeans:jar:2.3.0', '>2'*
>> > with
>> > *ns.xmlbeans! 'org.apache.xmlbeans:xmlbeans:jar:>=2.3.0'*
>> > in file
>> >
>> /jruby-1.7.12/lib/ruby/gems/shared/gems/buildr-1.4.17-java/addon/buildr/xmlbeans.rb
>> >
>> > This change successfully starts ODE build.
>> >
>> > Is this a bug or is there any other way to fix this?
>> >
>> > regards,
>> > sathwik
>>
>>
>>
>> --
>> Cheers,
>>
>> Peter Donald
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message