buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dieter Vrancken <>
Subject Re: stacktrace from JarTask
Date Thu, 11 May 2017 20:53:03 GMT
So I finally looked into this and figured out what the problem was.

Turns out we have a custom extension to obfuscate the :jar package.
This custom extension tried to avoid registering the :jar package
as a project artefact as nothing is supposed to be using that jar.
It did this by directly invoking 'package_as_jar', rather than
using 'package :jar'. As a result the code at package.rb:175 never
gets executed for this :jar package, the pom method is never defined
and I get the exception at java/packaging.rb:214. IMO, the extension
should instead just use a classifier to indicate the purpose of this

For my benefit, would you mind explaining the intent of the line at
java/packaging.rb:214? It's obviously trying to invoke the pom method,
but what does that achieve? My project does not use a pom or even a
maven repo for dependencies...

Thanks again for your time,

On 05/08/2017 07:53 PM, Peter Donald wrote:
> I expect the problem is probably a particular addon or feature you are
> using that we don't use in our projects. I just could not figure out
> which one would cause this. A small example to reproduce it would make
> the process a lot easier ;)
> On Mon, May 8, 2017 at 6:09 PM, Dieter Vrancken
> <> wrote:
>> Well that's just great :/ The interesting thing is that it does work as
>> expected with 1.5.0, without touching my buildfile. I will investigate
>> further and try to put something together in the coming days.
>> Thanks for looking into this,
>> Dieter
>> On 05/06/2017 01:11 PM, Peter Donald wrote:
>>> Hi,
>>> Using rbenv to install jruby- and using Buildr 1.5.2 I was
>>> unable to reproduce this error. I tried in three different projects.
>>> Do you have a small example project that reproduces this error?

View raw message