buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antoine Toulme <anto...@toulme.name>
Subject Re: buildr 1.5.3 not reading Rakefile
Date Mon, 24 Jul 2017 00:34:16 GMT
Sathwik,

We removed Rakefile support in 1.5.0. You need to rename the file to Buildfile.

> On Jul 21, 2017, at 12:26 AM, Sathwik B P <sathwik.bp@gmail.com> wrote:
> 
> Hi Antonie,
> I am using a docker container
> https://hub.docker.com/r/sathwik/apache-buildr/builds/bc9m569jxnezfvcneib2r4h/
> Java 8, Jruby 9.1.12.0, buildr 1.5.3
> 
> Stacktrace:
> latest-jruby-jdk8: Pulling from sathwik/apache-buildr
> Digest:
> sha256:4ebb64ed9d1623f1f0a5d1aebdf893d0eb88a988ef36aa0bc2342b03cc42e17e
> Status: Image is up to date for sathwik/apache-buildr:latest-jruby-jdk8
> OpenJDK 64-Bit Server VM warning: ignoring option MaxPermSize=512M; support
> was removed in 8.0
> Don't run Bundler as root. Bundler can ask for sudo if it is needed, and
> installing your bundle as root will break this application for all non-root
> users on this machine.
> Fetching gem metadata from https://rubygems.org/......
> Fetching version metadata from https://rubygems.org/.
> Using rake 0.9.2.2
> Using atoulme-Antwrap 0.7.5 (java)
> Using builder 3.2.2
> Using bundler 1.15.2
> Using diff-lcs 1.2.5
> Using jruby-openssl 0.9.20 (java)
> Using jruby-pageant 1.1.1 (java)
> Using json_pure 1.8.3
> Using minitar 0.5.4
> Using net-ssh 3.1.1
> Using rubyzip 1.2.0
> Using xml-simple 1.1.5
> Using nokogiri 1.6.8 (java)
> Fetching rspec-core 2.14.5
> Installing rspec-core 2.14.5
> Fetching rspec-mocks 2.14.3
> Installing rspec-mocks 2.14.3
> Fetching rspec-expectations 2.14.3
> Installing rspec-expectations 2.14.3
> Using net-sftp 2.1.2
> Using rspec 2.14.1
> Using buildr 1.5.3 (java)
> Bundle complete! 6 Gemfile dependencies, 19 gems now installed.
> Use `bundle info [gemname]` to see where a bundled gem is installed.
> OpenJDK 64-Bit Server VM warning: ignoring option MaxPermSize=512M; support
> was removed in 8.0
> Java is already loaded
> Java is already loaded
> Java is already loaded
> Buildr aborted!
> TypeError : no implicit conversion of nil into String
> org/jruby/RubyDir.java:304:in `chdir'
> /opt/jruby/lib/ruby/gems/shared/gems/buildr-1.5.3-java/lib/buildr/core/application.rb:385:in
> `find_buildfile'
> /opt/jruby/lib/ruby/gems/shared/gems/buildr-1.5.3-java/lib/buildr/core/application.rb:220:in
> `block in load_buildfile'
> /opt/jruby/lib/ruby/gems/shared/gems/buildr-1.5.3-java/lib/buildr/core/application.rb:534:in
> `standard_exception_handling'
> /opt/jruby/lib/ruby/gems/shared/gems/buildr-1.5.3-java/lib/buildr/core/application.rb:219:in
> `load_buildfile'
> /opt/jruby/lib/ruby/gems/shared/gems/buildr-1.5.3-java/lib/buildr/core/application.rb:129:in
> `block in run'
> /opt/jruby/lib/ruby/gems/shared/gems/buildr-1.5.3-java/lib/buildr/core/application.rb:534:in
> `standard_exception_handling'
> /opt/jruby/lib/ruby/gems/shared/gems/buildr-1.5.3-java/lib/buildr/core/application.rb:127:in
> `run'
> /opt/jruby/lib/ruby/gems/shared/gems/buildr-1.5.3-java/bin/buildr:20:in
> `<main>'
> org/jruby/RubyKernel.java:979:in `load'
> /usr/local/bin/buildr:22:in `<main>'
> 
> regards,
> sathwik
> 
> On Fri, Jul 21, 2017 at 11:47 AM, Antoine Toulme <antoine@toulme.name>
> wrote:
> 
>> What's the trace output? Souns like a bug to me.
>> 
>>> On Jul 20, 2017, at 22:41, Sathwik B P <sathwik@apache.org> wrote:
>>> 
>>> Hi Guys,
>>> 
>>> After upgrading to 1.5.3 from 1.4.25, buildr doesn't read Rakefile from
>> the
>>> current directory.
>>> Error encountered:
>>> TypeError : no implicit conversion of nil into String
>>> (See full trace by running task with --trace)
>>> 
>>> Explicit option with "-f Rakefile" works.
>>> 
>>> Is it mandatory now to explicitly specify the buildfile?
>>> 
>>> regards,
>>> sathwik
>> 


Mime
View raw message