bval-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Romain Manni-Bucau <rmannibu...@gmail.com>
Subject Re: BVal 2.0 TCK work
Date Thu, 19 Apr 2018 08:17:05 GMT
Pushed an (hopefully) fix, no issue to revert if it didn't help - I didnt
patch the tck so there is still a small "?" to have some regression.


Romain Manni-Bucau
@rmannibucau <https://twitter.com/rmannibucau> |  Blog
<https://rmannibucau.metawerx.net/> | Old Blog
<http://rmannibucau.wordpress.com> | Github <https://github.com/rmannibucau> |
LinkedIn <https://www.linkedin.com/in/rmannibucau> | Book
<https://www.packtpub.com/application-development/java-ee-8-high-performance>

2018-04-19 8:42 GMT+02:00 Romain Manni-Bucau <rmannibucau@gmail.com>:

> Will try to check today
>
> Le 19 avr. 2018 00:26, "Matt Benson" <mbenson@apache.org> a écrit :
>
>> Hi all,
>>   As of a few minutes ago our bv2 branch passes the 2.0 branch of the TCK
>> with the PR from BVTCK-205 built in... with the exception of a single
>> test, org.hibernate.beanvalidation.tck.tests.bootstrap.BootstrapCo
>> nfigurationTest.
>> What seems to be happening here is that our CDI extension is more eager
>> than the TCK wants it to be: if no one has injected the default
>> ValidatorFactory or its Validator, the test seems to rely on the
>> extension's not attempting to instantiate it. My CDI-fu is pretty weak if
>> anybody else wants to have a look at this.
>>
>> Matt
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message