calcite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Julian Hyde <jul...@hydromatic.net>
Subject Re: upgrading jetty-server
Date Wed, 04 Feb 2015 20:12:43 GMT
Feel free to log a jira case, but in my opinion it's not a huge problem: only the avatica-server
module depends on jetty, and you would probably only use that module if you are building a
calcite server. If you are embedding calcite you would not use that module and so would not
pull in jetty.

> On Feb 4, 2015, at 11:53 AM, Vladimir Sitnikov <sitnikov.vladimir@gmail.com> wrote:
> 
> Can we somehow isolate Calcite's Jetty so it does not interfere with
> client's jetties? (maven-shade-plugin ?)
> 
> Otherwise we would have to support multiple Jetty versions.
> 
> Vladimir
> 4 февр. 2015 г. 22:38 пользователь "Julian Hyde" <julian@hydromatic.net>
> написал:
> 
>> +1
>> 
>> Please log a jira case with a patch.
>> 
>>> On Feb 4, 2015, at 11:28 AM, Hartman, Trevor <thartman@ebay.com> wrote:
>>> 
>>> avatica-server specifies a dependency on jetty-server 7.6.8.v20121106
>> (released 06-Nov-2012).
>>> 
>>> Could it be upgraded to a newer version, e.g. 9.2.7.v20150116 (released
>> 16-Jan-2015)? I upgraded it in my local copy, made the necessary source
>> changes, and am using it since my project already has a dependency on the
>> newer version.
>>> 
>>> Trevor
>> 
>> 


Mime
View raw message