calcite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Altekruse <altekruseja...@gmail.com>
Subject Re: Dropping Java 6 support in Calcite
Date Mon, 09 Feb 2015 22:14:34 GMT
+1 Drill has only ever supported Java 7, while I do know their are some who
want to update hadoop clusters (as well as other systems that depend on
calcite) as infrequently as possible, we cannot carry the burden forever.

-Jason

On Mon, Feb 9, 2015 at 2:09 PM, Vladimir Sitnikov <
sitnikov.vladimir@gmail.com> wrote:

> +1 for dropping java 6 support.
>
> End of public updates for java 6 was in Feb 2013 (3 years ago).
> End of public updates for java 7 is somewhere in april 2015.
>
> I see little reason to support java 6.
>
> Vladimir
> 10 февр. 2015 г. 0:52 пользователь "Hartman, Trevor" <thartman@ebay.com>
> написал:
>
> > Please vote on whether to drop Java 6 support in Calcite.
> >
> > I added a patch [0] that upgrades jetty-server from 7.6.8.v20121106 to
> > 9.2.7.v20150116. Jetty 9.1+ requires Servlet 3.1 / Java 7+ [1]. Unless we
> > drop Java 6 support we won't be able to upgrade jetty-server above 8.x.
> >
> > [0] https://github.com/apache/incubator-calcite/pull/49
> > [1] https://webtide.com/jetty-9-2-0-released/
> >
> > Trevor
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message