calcite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Mior <michael.m...@gmail.com>
Subject Re: Dropping support for Guava versions earlier than 14
Date Sun, 04 Sep 2016 00:26:17 GMT
Calcite will work with Guava 16 and currently does use the Cassandra 3.x
driver.

--
Michael Mior
michael.mior@gmail.com
On Sep 3, 2016 05:03, "CPC" <achalil@gmail.com> wrote:

> Cassandra driver 3.x require min guava 16.0.1. If it detects an earlier
> version in classpath it stops working.
>
> On Sep 3, 2016 04:26, "Julian Hyde" <jhyde@apache.org> wrote:
>
> > James & Andrew, I hear you. We’ll stay on Guava 12 if we have to.
> >
> > But can we try an experiment to see if it’s possible to get away with 14?
> >
> > I propose that Maryann (who is developing the branch of Phoenix that uses
> > Calcite) tries running with https://github.com/apache/calcite/pull/277 <
> > https://github.com/apache/calcite/pull/277>. If we discover problems, we
> > can try various solutions, like make the DateRangeRules disabled by
> default
> > (these, and the Druid adapter, are the only parts of Calcite that need
> > Guava 14), or even copy the Guava classes that we need. If there aren’t
> > problems, it means that we’ve slipped out of the shackles of inertia that
> > are trying to drag us into an early grave.
> >
> > Julian
> >
> >
> > > On Sep 2, 2016, at 5:35 PM, James Taylor <jamestaylor@apache.org>
> wrote:
> > >
> > > On the server-side, HBase depends on Guava 12 (because Hadoop depends
> on
> > > the same). For that reason, we've made sure Phoenix can work with this
> > > version too. Phoenix may not need to depend on Calcite on the
> > server-side,
> > > and Phoenix and HBase both have shading, so there may be some avenues
> of
> > > escape.
> > >
> > > Sorry for the muddled answer.
> > >
> > > On Fri, Sep 2, 2016 at 5:21 PM, Andrew Purtell <apurtell@apache.org>
> > wrote:
> > >
> > >> Use of Guava 14 introduces at least a compile time problem with HBase,
> > upon
> > >> which Phoenix depends, so I'm not sure Phoenix can move off of 13. I'd
> > be
> > >> happy to be proven wrong.
> > >>
> > >> On Fri, Sep 2, 2016 at 4:35 PM, Julian Hyde <jhyde@apache.org> wrote:
> > >>
> > >>> Calcite currently supports a wide range of Guava versions, from
> 12.0.1
> > to
> > >>> 19.0*. For https://issues.apache.org/jira/browse/CALCITE-1334 <
> > >>> https://issues.apache.org/jira/browse/CALCITE-1334> I’d like to
use
> > >>> RangeSet, which was introduced in Guava 14.
> > >>>
> > >>> Would anyone have a problem if we made Calcite’s minimum Guava
> version
> > >>> 14.0.1?
> > >>>
> > >>> I see that Hive uses 14.0.1, Phoenix uses 13, Drill uses 18.
> > >>>
> > >>> Julian
> > >>>
> > >>> * Except for the Druid adapter, which requires 14; see
> > >>> https://issues.apache.org/jira/browse/CALCITE-1325 <
> > >>> https://issues.apache.org/jira/browse/CALCITE-1325>
> > >>
> > >>
> > >>
> > >>
> > >> --
> > >> Best regards,
> > >>
> > >>   - Andy
> > >>
> > >> Problems worthy of attack prove their worth by hitting back. - Piet
> Hein
> > >> (via Tom White)
> > >>
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message