calcite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Purtell <apurt...@apache.org>
Subject Re: Dropping support for Guava versions earlier than 14
Date Sat, 03 Sep 2016 00:21:22 GMT
Use of Guava 14 introduces at least a compile time problem with HBase, upon
which Phoenix depends, so I'm not sure Phoenix can move off of 13. I'd be
happy to be proven wrong.

On Fri, Sep 2, 2016 at 4:35 PM, Julian Hyde <jhyde@apache.org> wrote:

> Calcite currently supports a wide range of Guava versions, from 12.0.1 to
> 19.0*. For https://issues.apache.org/jira/browse/CALCITE-1334 <
> https://issues.apache.org/jira/browse/CALCITE-1334> I’d like to use
> RangeSet, which was introduced in Guava 14.
>
> Would anyone have a problem if we made Calcite’s minimum Guava version
> 14.0.1?
>
> I see that Hive uses 14.0.1, Phoenix uses 13, Drill uses 18.
>
> Julian
>
> * Except for the Druid adapter, which requires 14; see
> https://issues.apache.org/jira/browse/CALCITE-1325 <
> https://issues.apache.org/jira/browse/CALCITE-1325>




-- 
Best regards,

   - Andy

Problems worthy of attack prove their worth by hitting back. - Piet Hein
(via Tom White)

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message