calcite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Julian Hyde <jh...@apache.org>
Subject Dropping support for Guava versions earlier than 14
Date Fri, 02 Sep 2016 23:35:55 GMT
Calcite currently supports a wide range of Guava versions, from 12.0.1 to 19.0*. For https://issues.apache.org/jira/browse/CALCITE-1334
<https://issues.apache.org/jira/browse/CALCITE-1334> I’d like to use RangeSet, which
was introduced in Guava 14.

Would anyone have a problem if we made Calcite’s minimum Guava version 14.0.1?

I see that Hive uses 14.0.1, Phoenix uses 13, Drill uses 18.

Julian

* Except for the Druid adapter, which requires 14; see https://issues.apache.org/jira/browse/CALCITE-1325
<https://issues.apache.org/jira/browse/CALCITE-1325>
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message