calcite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From F21 <f21.gro...@gmail.com>
Subject Re: is Travis build for master broken
Date Tue, 04 Oct 2016 23:48:33 GMT
Hey Julian,

Thanks for the tip! Wercker clones with a depth of 50 by default. I have 
now added a few more commands to convert the shallow clone to a full clone.

I am now able to run the tests and get them passing. Wercker is also 
quite stable, I ran the tests a few times and they all pass each time.

Compare to travis, wercker is also much faster, tests take about 9 
minutes to run compared to the 25ish minutes with travis.

Would you be interested in moving the CI over to wercker? You can check 
out my branch here: https://github.com/F21/calcite/tree/use-wercker 
(.travis.yml is replaced with wercker.yml).

Cheers,
Francis

On 5/10/2016 3:08 AM, Julian Hyde wrote:
> Francis,
>
> Try removing the depth argument when you do 'git clone'.
>
> Julian
>
>> On Oct 3, 2016, at 21:30, F21 <f21.groups@gmail.com> wrote:
>>
>> I tried to force travis to use a standard trusty vm in https://github.com/apache/calcite/pull/293,
so that the VM is assigned 7.5GB of memory. Unfortunately, travis is still quite flaky, with
tests only passing some of the time.
>>
>> Would it be useful to move to another CI? I tried setting up my fork to use wercker:
https://github.com/F21/calcite/blob/use-wercker/wercker.yml which failed here: https://app.wercker.com/F21/calcite/runs/build-jdk-7/57f3172e3b89220100273603?step=57f3173814732000019140d0
>>
>> Unfortunately, I haven't found a solution to this error:
>>
>> [ERROR] Failed to execute goal pl.project13.maven:git-commit-id-plugin:2.1.9:revision
(default) on project calcite: Execution default of goal pl.project13.maven:git-commit-id-plugin:2.1.9:revision
failed: Unable to calculate distance between [commit be18b25415a305aab2d0de2bd074755630e08462
1475548960 ----sp] and [commit 08c56b158ffcfcf205a919cc9fff77a692e649f6 1474099831 ----sp]:
Missing commit 63c51d0c6459a4de5cab01188a7f3b7dd1a259fb -> [Help 1]
>>
>> Francis
>>
>>> On 4/10/2016 10:55 AM, Julian Hyde wrote:
>>> I’ve noticed it. A lot of Travis builds seem to hang. See the last two lines
of https://travis-ci.org/apache/calcite/jobs/163844678: <https://travis-ci.org/apache/calcite/jobs/163844678:>
>>>
>>>>   No output has been received in the last 10 minutes, this potentially
>>>> indicates a stalled build or something wrong with the build itself.
>>>>
>>>> The build has been terminated
>>> I don’t know why Travis does this. I suspect that the Travis VM doesn’t have
enough memory to complete the task, or the job takes longer than Travis allows, but these
are wild guesses.
>>>
>>> I have been running the build and tests on my own Linux server in a variety of
configurations (in particular JDK 1.7 and 1.8, and a couple of timezones, and occasionally
also on macOS and Windows), and I can confirm that everything is stable.
>>>
>>> Julian
>>>
>>>
>>>> On Oct 3, 2016, at 3:20 PM, Laurent Goujon <laurent@dremio.com> wrote:
>>>>
>>>> Hi,
>>>>
>>>> I just opened a pull request against Calcite master, and the travis build
>>>> failed. But then I checked the master branch, and according to Travis, it's
>>>> also failing.
>>>>
>>>> Is it something known, or just a transient issue?
>>>>
>>>> Thanks in advance,
>>>>
>>>> Laurent



Mime
View raw message