cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wenjun (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CASSANDRA-4078) StackOverflowError when upgrading to 1.0.8 from 0.8.10
Date Mon, 02 Apr 2012 15:35:23 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-4078?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13244256#comment-13244256
] 

Wenjun commented on CASSANDRA-4078:
-----------------------------------

I am able to fix the issue by doing the followings:

1. ran original command for creating the CF (replacing create with update) in cassandra-cli,
got an error "cannot modify index name". (I looked it up in Cassandra mailing list and did
not found any reference, so not sure what it means).

2. ran the command again WITHOUT index in column_metadata.

3. ran the command WITH index in column_metadata.

Now I am able to start 1.0.8 and 1.1.0-beta2.  I double-checked that CF and it seems all the
data and index are fine.  So, let me know if I need to check anything else.

Thanks



                
> StackOverflowError when upgrading to 1.0.8 from 0.8.10
> ------------------------------------------------------
>
>                 Key: CASSANDRA-4078
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-4078
>             Project: Cassandra
>          Issue Type: Bug
>          Components: Core
>    Affects Versions: 0.8.10
>         Environment: OS: Linux xps.openfin 2.6.35.13-91.fc14.i686 #1 SMP Tue May 3 13:36:36
UTC 2011 i686 i686 i386 GNU/Linux
> Java: JVM vendor/version: Java HotSpot(TM) Server VM/1.6.0_31
>            Reporter: Wenjun
>            Assignee: paul cannon
>            Priority: Critical
>             Fix For: 0.8.10
>
>         Attachments: 4078.add-asserts.txt, cassandra.yaml.1.0.8, cassandra.yaml.8.10,
keycheck.txt, system.log, system.log.0326, system.log.0326-02
>
>
> Hello
> I am trying to upgrade our 1-node setup from 0.8.10 to 1.0.8 and seeing the following
exception when starting up 1.0.8.  We have been running 0.8.10 without any issues.
>  
> Attached is the entire log file during startup of 1.0.8.  There are 2 exceptions:
> 1. StackOverflowError (line 2599)
> 2. InstanceAlreadyExistsException (line 3632)
> I tried "run scrub" under 0.8.10 first, it did not help.  Also, I tried dropping the
column family which caused the exception, it just got the same exceptions from another column
family.
> Thanks

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message