cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jacob Rhoden (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CASSANDRA-6021) Creating keyspace fails with cryptic error.
Date Fri, 13 Sep 2013 07:45:51 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-6021?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13766310#comment-13766310
] 

Jacob Rhoden commented on CASSANDRA-6021:
-----------------------------------------

Workaround is to use a different syntax. (I am a little confused because I am sure the former
syntax worked on this laptops installation of cassandra).

CREATE KEYSPACE base_test WITH replication = {'class': 'SimpleStrategy', 'replication_factor':
1};
                
> Creating keyspace fails with cryptic error.
> -------------------------------------------
>
>                 Key: CASSANDRA-6021
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-6021
>             Project: Cassandra
>          Issue Type: Bug
>          Components: API
>         Environment: Cassandra 1.2.8 installed on Mac (OS X 10.9 patch 7)
>            Reporter: Jacob Rhoden
>            Priority: Critical
>
> Creating a keyspace returns a strange and cryptic error. (Java exception falling through
to cqlsh)
>     cqlsh> create keyspace base_test with strategy_options = {replication_factor:1}
and placement_strategy='org.apache.cassandra.locator.SimpleStrategy';
>     Bad Request: Failed parsing statement: [create keyspace base_test with strategy_options
= {replication_factor:1} and placement_strategy='org.apache.cassandra.locator.SimpleStrategy';]
reason: NullPointerException null
> I've tried increasing the logging level but I cant seem to get any more info about it.
If there is other information I can provide that might be useful please let me know.
> Im still learning cassandra so its possible im doing something stupid, but either way,
a null pointer exception is not an ideal error message.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message