cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dave Brosius (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CASSANDRA-8168) Require Java 8
Date Mon, 24 Nov 2014 17:23:14 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-8168?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14223159#comment-14223159
] 

Dave Brosius commented on CASSANDRA-8168:
-----------------------------------------

{quote}
One thing I've learned is java 8 should give us some performance boost due to improvements
in CAS contention improvements. We use these types extensively on the hot path
http://ashkrit.blogspot.com/2014/02/atomicinteger-java-7-vs-java-8.html
{quote}

Yes but isn't that the JVM doing that? Compiling with 8 shouldn't effect that.

I'm not a big fan of going to 8 at the moment, to me, just because i'm not sure the added
value outweighs the pain you add to users.

> Require Java 8
> --------------
>
>                 Key: CASSANDRA-8168
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-8168
>             Project: Cassandra
>          Issue Type: Task
>            Reporter: T Jake Luciani
>            Assignee: T Jake Luciani
>             Fix For: 3.0
>
>
> This is to discuss requiring Java 8 for version >= 3.0  
> There are a couple big reasons for this.
> * Better support for complex async work  e.g (CASSANDRA-5239)    http://docs.oracle.com/javase/8/docs/api/java/util/concurrent/CompletableFuture.html
> * Use Nashorn for Javascript UDFs CASSANDRA-7395



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message