cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sam Tunnicliffe (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CASSANDRA-14457) Add a virtual table with current compactions
Date Mon, 04 Jun 2018 11:34:00 GMT

    [ https://issues.apache.org/jira/browse/CASSANDRA-14457?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16500102#comment-16500102
] 

Sam Tunnicliffe commented on CASSANDRA-14457:
---------------------------------------------

Nice, this looks really good. [~cnlwsu] if you don't mind me chipping in, I have a couple
of comments on naming.


Could we avoid the requirement to quote some column names by adopting the pattern used in
system tables? {{keyspace_name/table_name}} would remove the need to quote and be consistent
with existing tables.


Using {{undefined}} for tasks without a specific keyspace/table won't really fly as that's
a perfectly valid identifier. For tasks without a specific target how about using values which
are totally illegal for actual keyspace/table names like {{"all keyspaces"}} and {{"all tables"}}?


I understand that the naming of the non-primary key columns is designed to make the layout
in cqlsh user friendly, but I think we could achieve the same thing with a bit more meaningful
naming ({{progess_total}} for example, is a bit unintuitive). OTOMH, a set of column names
like {{kind, progress, size, unit}} would produce a usable display and communicate what the
columns represent a bit better.


Lastly, I'm a bit bothered by this being named the {{compactions}} table and described as
a "{{List of current compactions}}" when there's a whole bunch of operations that are going
to show up in this table which have little to do with compaction, except for the fact that
they may be utilising some resources from the compaction pool. I'm not suggesting that they
shouldn't be included here, they definitely should be if this table is to be used in the same
way as nodetool compactionstats is currently, but seeing as this both user facing and something
of a blank canvas I think we should try to get this sort of thing as right as we can up front.
 My vote would be to rename this to something like {{sstable_tasks}} and open a separate jira
to create an actual {{compactions}} table which would "contain" a strict subset of the data
exposed here.


> Add a virtual table with current compactions
> --------------------------------------------
>
>                 Key: CASSANDRA-14457
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-14457
>             Project: Cassandra
>          Issue Type: New Feature
>            Reporter: Chris Lohfink
>            Assignee: Chris Lohfink
>            Priority: Minor
>             Fix For: 4.x
>
>




--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscribe@cassandra.apache.org
For additional commands, e-mail: commits-help@cassandra.apache.org


Mime
View raw message