cassandra-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joseph Lynch (JIRA)" <>
Subject [jira] [Commented] (CASSANDRA-14761) Rename speculative_retry to match additional_write_policy
Date Sat, 03 Nov 2018 00:42:00 GMT


Joseph Lynch commented on CASSANDRA-14761:

Just a quick pass, it looks like most of it was just search and replace of speculative with
 * As a user I find this new naming pretty confusing, and I'm curious what other users think.
I think there is significant mind-share in the community and indeed other distributed systems
(e.g. hadoop) around the concept of {{speculative}} execution of idempotent operations. If
anything I think it makes sense to do {{speculative_read_policy}} and {{speculative_transient_write_policy}}.
Even if we keep the {{additional_read_policy}} and {{additional_write_policy}} naming I worry
a user could easily confuse these somewhat different features (I know that I was confused
at first).
 * I think most of the failing dtests are coming from [the unconditional check |]
that the objects are equal even if one isn't set. Perhaps only check they are equal if they
are both set?. Also the string format swaps speculativeRetry with additionReadPolicy (which
should probably be additional).
 * (docs) Did you mean to [remove the speculative read option|]?
I think you would want both {{additional_write}} and {{additional_read}} in the table?
 * (docs) If I understand speculative transient replica upgrade right, this [text|]
no longer applies to just read coordinators.
 * (metrics) {{AdditionalReadsFailed}} [appears to be inconsistent|]
with the other new in 4.0 metrics ({{SpeculativeInsufficientRetries}} and {{SpeculativeSampleLatencyNanos}}).
Personally I like the Speculative name across the board (esp since if we change {{SpeculativeRetries}}
it's not backwards compatible).

> Rename speculative_retry to match additional_write_policy
> ---------------------------------------------------------
>                 Key: CASSANDRA-14761
>                 URL:
>             Project: Cassandra
>          Issue Type: Improvement
>          Components: Core
>            Reporter: Ariel Weisberg
>            Assignee: Ariel Weisberg
>            Priority: Major
>             Fix For: 4.0
> It's not really speculative. This commit is where it was last named and shows what to

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message