chukwa-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eric Yang (JIRA)" <>
Subject [jira] Resolved: (CHUKWA-556) Remove Hadoop_ prefix from Hadoop Metrics Processor
Date Sun, 14 Nov 2010 07:26:13 GMT


Eric Yang resolved CHUKWA-556.

    Resolution: Duplicate

> Remove Hadoop_ prefix from Hadoop Metrics Processor
> ---------------------------------------------------
>                 Key: CHUKWA-556
>                 URL:
>             Project: Chukwa
>          Issue Type: Improvement
>          Components: Data Processors
>         Environment: Java 6, MacOSX 10.6
>            Reporter: Eric Yang
>            Assignee: Eric Yang
> Both Chukwa and HBase uses MetricsContext to emite Hadoop metrics format.  Therefore,
it is possible to reuse the same HadoopMetricsProcessor class to process those metrics.  In
HadoopMetricsProcessor is currently prepending Hadoop_ into the metrics field name.  This
jira is to remove this prefix.  The DataType will be base on the user input type.  i.e. Hadoop,
Chukwa, HBase, and column family or field name will be set to contextName of the MetricsContext.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message