cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alena Prokharchyk <>
Subject Re: Anyone try upgrading from 2.2.14 to 3.0.2?
Date Wed, 23 May 2012 19:15:29 GMT
On 5/23/12 8:55 AM, "Jason Davis" <> wrote:

>I've tried the upgrade in my development environment and this has largely
>worked other than the fact that the API command "listHosts" seems to now
>broken. I've also tried doing a clean install of 3.0.2 and then restoring
>backup copy of my MySQL DB of the 2.2.14-3.0.2 upgrade and still encounter
>the same issue.
>I've opened a bug report here:
>Just curious if anyone else has tried this and have had this work

The bug indicates that there are some references in
"cloud.storage_pool_host_ref" table to the removed Local Storage instance
("cloud.storage_pool" table). The references were supposed to be removed
along with the storage removal, but due to some bug they were left around.

To debug the problem, I need the mysql db dumps of following cloudStack
tables (2 versions - before and after upgrade):

* host
* storage_pool_host_ref
* storage_pool;


View raw message