cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Prasanna Santhanam <>
Subject Re: Getting CRAZY for having a cloud working!
Date Thu, 27 Dec 2012 19:33:24 GMT
On Thu, Dec 27, 2012 at 08:28:02PM +0530, Andrea Ottonello wrote:
> Hallo Sebastien,
> thank you for your help.
> I will try to put management log on the site you provided.
> I started using 4.0 version, tried 3.0 only searching for a solution.
> Let's answer something:
> 1- yes management server is running
> 2- yes I defined zone, pod, cluster and host.
> 3- primary and secondary are defined and available.
> 4- I can mount NFS secondary storage and create file inside it from host,
> primary is locally available to host (HBA) and I can create a VM on it
> using XenCenter, so is online and working.
> I also tried using NFS share for primary, or even localstorage (enabling
> global config varable to use it for VMs).
> 5- zone is enabled.
> 6- VMs are NOT running. v-2-VM is in starting/stopped state loop, while if
> I enable zone CS tries to create s-XX-VM, it fails, it deletes it and try
> again creating a new one, increasing XX number of 1, in an infinite loop.
> This is definitely my problem. If I look at management log, it says that my
> only available host is in avoid set, so CS doesn't know where to put VM and
> fails. I don't know WHY my host is in "avoid set": it has 22 GB of RAM, 200
> GB of primary storage and 2 CPU quadcore. It is a fresh install, formatted
> and only putted into a new pool as for installation instructions. I used
> same name for network interfaces and primary storage. There must be
> something wrong/missing in Xen/XCP setup, but I'm not able to understand
> what. Is terribly frustrating...

If using the OSS builds/building from source make sure the vhd-util
binary is placed on the management server before adding Xen hosts [1]:

This was documented in the release docs, but not sure if you have the
updated docs.

Pl. do read through


View raw message